Cannot disable 'Use Touch ID' using the passcode

VERIFIED FIXED in 3.0

Status

()

Firefox for iOS
Login Management
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: csuciu, Assigned: sleroux)

Tracking

unspecified
All
iOS

Firefox Tracking Flags

(fxios-v3.0 verified, fxios-v4.0 verified, fxios3.0+)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
v3.0b7
iPhone 6 Plus (9.2.1)

1. Turn passcode on in iOS settings
2. Turn passcode on in Firefox settings
3. Enable Use Touch ID in Firefox settings
4. Try to disable 'Use Touch ID'. When prompted for the fingerprint, provide one that is not store in iOS settings
5. When prompted to try again, select enter passcode
6. Provide the correct passcode

Expected: 'Use Touch ID' option will be disabled

Actual: Nothing happens after providing the correct passcode. The prompt for passcode does not close. If I close it from the 'Close' button, 'Use Touch ID' is still on.
(Reporter)

Updated

2 years ago
Blocks: 1198418
tracking-fxios: ? → 3.0+
Flags: needinfo?(sleroux)
(Assignee)

Updated

2 years ago
Assignee: nobody → sleroux
Status: NEW → ASSIGNED
Flags: needinfo?(sleroux)
(Assignee)

Comment 1

2 years ago
Created attachment 8733480 [details] [review]
Github PR https://github.com/mozilla/firefox-ios/pull/1656

This patch also fixes https://bugzilla.mozilla.org/show_bug.cgi?id=1258738
Attachment #8733480 - Flags: review?(sarentz)
Attachment #8733480 - Flags: review?(bnicholson)
Comment on attachment 8733480 [details] [review]
Github PR https://github.com/mozilla/firefox-ios/pull/1656

Tested on iPhone 6s. LGTM!
Attachment #8733480 - Flags: review?(sarentz)
Attachment #8733480 - Flags: review?(bnicholson)
Attachment #8733480 - Flags: review+
Whiteboard: [needsuplift]
(Assignee)

Comment 3

2 years ago
master a6c672fdfccd02749f408108e2b6e16f7fb3d1c1
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-fxios-v4.0: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → 4.0
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1258738
(Reporter)

Comment 5

2 years ago
Verifying as fixed on master a6c672f.
status-fxios-v4.0: fixed → verified
(Assignee)

Comment 6

2 years ago
v3.x 18d8103
status-fxios-v3.0: affected → fixed
Whiteboard: [needsuplift]
Target Milestone: 4.0 → 3.0
(Reporter)

Comment 7

2 years ago
On build 3.0b8 I can disable 'Use Touch ID' using the passcode.

Verified as fixed.
Status: RESOLVED → VERIFIED
status-fxios-v3.0: fixed → verified
You need to log in before you can comment on or make changes to this bug.