Open Web App quits right after you dismiss warning dialog on DevEdition

RESOLVED FIXED in Firefox 47

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: myk, Assigned: myk)

Tracking

47 Branch
Firefox 47
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox46 unaffected, firefox47 fixed, firefox48 unaffected)

Details

Attachments

(1 attachment)

Assignee

Description

3 years ago
Bug 1252635 introduced a regression that breaks app startup on DevEdition, right after you dismiss the warning dialog.  Here's the fix.  (We could also back out the fix for that bug, which would resolve the app startup issue, although it would reintroduce the error that bug was intended to resolve.)
Attachment #8733483 - Flags: review?(mcastelluccio)
Assignee

Comment 1

3 years ago
Note that the patch is for the Aurora branch, which is the only branch that has the fix for bug 1252635 (since that fix was introduced in 47, and the runtime was removed in 48).
Attachment #8733483 - Flags: review?(mcastelluccio) → review+
Assignee

Comment 2

3 years ago
Comment on attachment 8733483 [details] [diff] [review]
ensure window before trying to use it

Approval Request Comment
[Feature/regressing bug #]: bug 1252635

[User impact if declined]: Users of Open Web Apps will no longer be able to run their apps, as they will quit on startup.

[Describe test coverage new/current, TreeHerder]: This code isn't tested automatically, but I've manually verified the (simple and obvious) fix.

[Risks and why]: Low risk.

[String/UUID change made/needed]: None.
Attachment #8733483 - Flags: approval-mozilla-aurora?
Comment on attachment 8733483 [details] [diff] [review]
ensure window before trying to use it

recent regression in 47, taking it.
Attachment #8733483 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
You need to log in before you can comment on or make changes to this bug.