Closed Bug 1258807 Opened 4 years ago Closed 4 years ago

Conditional breakpoint is gone

Categories

(DevTools :: Debugger, defect, P1)

defect

Tracking

(firefox45 affected, firefox46 affected, firefox47 affected, firefox48 fixed, firefox-esr45 affected)

RESOLVED FIXED
Firefox 48
Tracking Status
firefox45 --- affected
firefox46 --- affected
firefox47 --- affected
firefox48 --- fixed
firefox-esr45 --- affected

People

(Reporter: magicp.jp, Assigned: jlong)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160322030417

Steps to reproduce:

1. Start Nightly
2. Go to any sites (e.g. about:home)
3. Open Debugger
4. Select any source items
5. Add a conditional breakpoint with expression
6. Disable (check-off) the conditional breakpoint (not remove)
7. Enable (check-on) the conditional breakpoint remain opening the expression panel 


Actual results:

[Aurora, Nightly]
The conditional breakpoint is gone from side panel.

[Firefox 45.0.1, 46.0b2]
The conditional breakpoint on line number is gone. And also cannot select its source item.


Expected results:

Conditional breakpoint check-on works correctly.
Has STR: --- → yes
Component: Untriaged → Developer Tools: Debugger
OS: Unspecified → All
Hardware: Unspecified → All
Version: Trunk → unspecified
James, you recently made a change in how we enable/disable conditional breakpoints. Could this be a regression?

In any case, this should be fixed asap. Marking as p1.
Flags: needinfo?(jlong)
Priority: -- → P1
Assignee: nobody → jlong
Flags: needinfo?(jlong)
Attached patch 1258807.patchSplinter Review
Thanks for these excellent bug reports. The problem was updating a breakpoint's condition when it's disabled; this patch fixes that. The rogue breakpoint in the editor was because of a bug introduced in the patch that colors conditional breakpoints differently.

I've expanded the test cases to handle this.
https://hg.mozilla.org/mozilla-central/rev/24b5fb250c49
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.