'abort: out of memory' when running |hg qbackout|

RESOLVED DUPLICATE of bug 1258838

Status

mozilla.org
MozillaBuild
RESOLVED DUPLICATE of bug 1258838
2 years ago
2 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Details

MozillaBuild 2.2.0pre4 on Windows 8.1 64 bit

Tried to backout this push https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=b21390b218bf and saw a message about out of memory for the first time since I do backouts. Python uses one CPU hyperthread to 100% (will file a different bug about this one). Hadn't used previous 2.2.0pre versions.

I@Computer /c/Mozilla/Coding/Code/mozilla-inbound
$ hg qbackout -r ff81c52375ba:0516f9a5ad9d
checking for uncommitted changes
backing out ff81c52375ba
applying patch from stdin
backing out cf816f733296
applying patch from stdin
backing out 08f1c7239cdf
applying patch from stdin
backing out c4faeb0be959
applying patch from stdin
backing out 6e95ee3cd4c6
applying patch from stdin
backing out 83dfa9e03d0e
applying patch from stdin
backing out 1b5db6edd791
applying patch from stdin
backing out 6403c45366e0
applying patch from stdin
backing out 8bb1cce4804d
applying patch from stdin
backing out 2603e80db18f
applying patch from stdin
backing out c2e6b3fb0892
applying patch from stdin
backing out 0516f9a5ad9d
applying patch from stdin
abort: out of memory

I@Computer /c/Mozilla/Coding/Code/mozilla-inbound
$ hg qseries
backout-ff81c52375ba
backout-cf816f733296
backout-08f1c7239cdf
backout-c4faeb0be959
backout-6e95ee3cd4c6
backout-83dfa9e03d0e
backout-1b5db6edd791
backout-6403c45366e0
backout-8bb1cce4804d
backout-2603e80db18f
backout-c2e6b3fb0892
hrm, I wasn't able to reproduce :\

Ryan@StarsEnd ~/repos/mozilla-central
$ hg up -C -r b21390b218bf
190 files updated, 0 files merged, 5 files removed, 0 files unresolved

Ryan@StarsEnd ~/repos/mozilla-central
$ hg qbackout -r ff81c52375ba:0516f9a5ad9d
checking for uncommitted changes
backing out ff81c52375ba
applying patch from stdin
backing out cf816f733296
applying patch from stdin
backing out 08f1c7239cdf
applying patch from stdin
backing out c4faeb0be959
applying patch from stdin
backing out 6e95ee3cd4c6
applying patch from stdin
backing out 83dfa9e03d0e
applying patch from stdin
backing out 1b5db6edd791
applying patch from stdin
backing out 6403c45366e0
applying patch from stdin
backing out 8bb1cce4804d
applying patch from stdin
backing out 2603e80db18f
applying patch from stdin
backing out c2e6b3fb0892
applying patch from stdin
backing out 0516f9a5ad9d
applying patch from stdin
I repeated the steps and saw a maximum memory usage of ~1.1GB for python.exe during the backout. Not great, but far from OOM-imminent AFAICT.
Also occurs with MozillaBuild 2.1.0. Peak of reserved address space is ~1.8GB.
No longer blocks: 1224680
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1258838
You need to log in before you can comment on or make changes to this bug.