Closed Bug 1258958 Opened 5 years ago Closed 5 years ago

Input via WinAPI SendInput doesn't work

Categories

(Core :: Widget: Win32, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1263389

People

(Reporter: xidorn, Unassigned)

Details

Attachments

(1 file)

Attached file test program
The attachment is a test program and its source code.

Steps to reproduce:
1. open the test program SendKeysTest.exe;
2. switch to Firefox and make any text box on focus;
3. switch back to the test program and input some text;
4. click the "Send Keys" button and immediately switch to Firefox.

Expected result:
The text inputed in the test program will be sent to the text box on focus after 1s.

Actual result:
Nothing is inputed.


This is a regression from this push: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=1e4ee08ece89 so it could be one of bug 1137512, bug 1137572, bug 1137561, bug 1137565, and bug 1137563.
I don't know whether it helps to bring that issue forward, but let me confirm this bug.

I'm using an advanced keyboard layout modification (foreign language symbols, smileys, etc.) performed in AutoHotkey using DLL calls for direct interfacing with SendInput, and this method used to work for years but stopped to do so suddenly in March 2016. Copy&Paste from another application like an editor works, however.

Please fix!
I forgot this bug. I guess that this is dup of bug 1263389.
This issue can be closed, at least for me it works again. Perhaps the OP wants to have the last word, though.
Confirmed that this was fixed by bug 1263389. It can be reproduced with 7aeac9da4265 but not 14a02164b038.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1263389
You need to log in before you can comment on or make changes to this bug.