Remove en-* conditional on newsletter title

RESOLVED FIXED

Status

www.mozilla.org
L10N
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: flod, Assigned: flod)

Tracking

(Depends on: 1 bug)

Production

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

2 years ago
Filing a bug before it gets forgotten.

https://github.com/mozilla/bedrock/pull/3995/files
This added a new title for the newsletter block, we need to remove it as soon as it has a good l10n coverage (string hasn't been exposed yet).
Thanks Flod. Quick clarifying question: this isn't to remove the "(English only)" blurb that shows up automatically when email newsletters are in English only - but instead to remove this string from the l10n process until it has l10n coverage/change the way that this blurb is localized. Right?
(Assignee)

Comment 2

2 years ago
(In reply to Jessilyn Davis from comment #1)
> Thanks Flod. Quick clarifying question: this isn't to remove the "(English
> only)" blurb that shows up automatically when email newsletters are in
> English only - but instead to remove this string from the l10n process until
> it has l10n coverage/change the way that this blurb is localized. Right?

Currently the title 'Keep up with all things Firefox.' (in the footer block) is only used for en-*, localized pages still use 'Get Firefox news.'. As soon as we have enough localizations for the new string, we'll need to enable the new title for l10n too. No practical changes for en-US.
Sweet! Thanks Flod!
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1258447
We will also need to clean up the button copy here:
bedrock/newsletter/templates/newsletter/includes/form.html
(Assignee)

Comment 6

2 years ago
We have over 90% coverage for both new strings, we're good to remove the conditionals.
Assignee: nobody → francesco.lodolo

Comment 7

2 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/41662508190c5fa75d85746cf36575f4229004d2
Fix bug 1258998 - Remove en-* conditional on newsletter title and button

Remove conditionals introduced in #3995 and #4023

https://github.com/mozilla/bedrock/commit/30c93d4c32d6cb48b73fc5f80676ed0ba775f3af
Merge pull request #4071 from flodolo/bug1258998

Fix bug 1258998 - Remove en-* conditional on newsletter title and button

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.