Closed Bug 1259024 Opened 4 years ago Closed 4 years ago

developer-toolbar-closebutton has wrong tooltiptext

Categories

(DevTools Graveyard :: Graphic Commandline and Toolbar, defect)

defect
Not set

Tracking

(firefox45 unaffected, firefox46 unaffected, firefox47 wontfix, firefox48 verified, firefox-esr45 unaffected)

VERIFIED FIXED
Firefox 48
Tracking Status
firefox45 --- unaffected
firefox46 --- unaffected
firefox47 --- wontfix
firefox48 --- verified
firefox-esr45 --- unaffected

People

(Reporter: magicp.jp, Assigned: ochameau)

References

Details

Attachments

(2 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160322030417

Steps to reproduce:

1. Start Nightly (or Aurora)
2. Open the Developer Toolbar (Shift + F2)
3. Confirm tooltiptext of developer-toolbar-closebutton


Actual results:

tooltiptext is "developerToolbarCloseButton.tooltiptext"


Expected results:

tooltiptext is "Close Developer Toolbar"
Regression range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4295f9951e9331a2f2bd0a8ea8c4ad73af141a7b&tochange=9da51cb4974e03cdd8fa45a34086fe1033abfeaf
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Developer Tools: Graphic Commandline and Toolbar
OS: Unspecified → All
Hardware: Unspecified → All
Blocks: 1216478
Flags: needinfo?(gijskruitbosch+bugs)
bug 1216478 did not cause this. Please always continue with mozregression to get an fx-team/inbound regression range. Don't assume that changesets with the right word in their summary are necessarily at fault.

Looking at the code here, this was caused by bug 1248601.
Blocks: 1248601
No longer blocks: 1216478
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(poirot.alex)
Assignee: nobody → poirot.alex
Flags: needinfo?(poirot.alex)
Attached patch patch v1 (obsolete) — Splinter Review
Attached patch patch v2Splinter Review
I'm moving these dtd to properties as dtd only works in static documents.
(i.e. don't work on dynamically inserted XUL elements)

But note that the close icon is completely gone in my local build.
I can't say if it is related to some other patch in my queue or bug 1257348.

(reverting bug 1257348 made it visible again, except on hover)
Attachment #8735811 - Flags: review?(jwalker)
Attachment #8735799 - Attachment is obsolete: true
Attachment #8735811 - Flags: review?(jwalker) → review+
(In reply to Alexandre Poirot [:ochameau] from comment #4)
> But note that the close icon is completely gone in my local build.
> I can't say if it is related to some other patch in my queue or bug 1257348.
> 
> (reverting bug 1257348 made it visible again, except on hover)

Is there a separate bug on file about this issue?
Flags: needinfo?(poirot.alex)
Not that I know of. Are you able to reproduce?
I'm very surprised bug 1257348 would regress exactly what it was attempting to fix?!!

Did you verified bug 1257348? Does close button works fine for you?
Would it be linux specific?
Flags: needinfo?(poirot.alex) → needinfo?(bgrinstead)
(In reply to Alexandre Poirot [:ochameau] from comment #6)
> Not that I know of. Are you able to reproduce?

I didn't try. I took your word for it! :-)
It sounded like you were seeing a separate problem to this bug, namely that the close icon wasn't showing up except when hovered - is that right? If so, especially if you can reproduce on today's nightly (you might have to force download it, updates are off atm) then you can file it and we can investigate more there? :-)
Ok, I'm able to reproduce on Linux from a 03/30 build.
Not on windows, from a 03/29 build (I imagine bug 1257348 is already in this build)

So it seems to be OS specific.
Flags: needinfo?(bgrinstead)
Opened bug 1260751.
Ready to land once fxteam reopens.
https://hg.mozilla.org/integration/fx-team/rev/21be9fc9356d9ee4f396a5263b0aa1b47266eb8a
Bug 1259024 - Fix developer toolbox close and toolbar toggle button tooltips. r=jwalker
https://hg.mozilla.org/mozilla-central/rev/21be9fc9356d
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
Duplicate of this bug: 1260038
Depends on: 1296490
Verified in 48.
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.