All users were logged out of Bugzilla on October 13th, 2018

In SVG, 'writing-mode' should work as a presentation attribute.

RESOLVED DUPLICATE of bug 1158500

Status

()

RESOLVED DUPLICATE of bug 1158500
3 years ago
3 years ago

People

(Reporter: tavmjong, Unassigned)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8733866 [details]
text-wrap-vertical.svg

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160319030558

Steps to reproduce:

Load the attached file (from the SVG 2 specification) with <text writing-mode="tb-rl">. writing-mode is an SVG 1.1 presentation attribute so it should be supported. Rendering is correct if writing-mode is used in a style sheet or style attribute.


Actual results:

Characters are laid out horizontally.


Expected results:

Characters should be laid out vertically.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1158500
You need to log in before you can comment on or make changes to this bug.