The mystery of the disappearing location property

RESOLVED DUPLICATE of bug 1251361

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 1251361
2 years ago
2 years ago

People

(Reporter: Ms2ger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

230 bytes, text/html
Details
35 bytes, application/xml
Details
771 bytes, text/html
Details
(Reporter)

Description

2 years ago
#1  0x0000000102659c4a in JS::Heap<JS::Value>::operator= (this=0x121a893d8, p=@0x7fff5fbfbeb0) at RootingAPI.h:242
#2  0x0000000105652197 in mozilla::dom::DOMProxyHandler::GetAndClearExpandoObject (obj=0x159461280) at DOMJSProxyHandler.cpp:93
#3  0x00000001045e662d in nsWrapperCache::ReleaseWrapper (this=0x121a89008, aScriptObjectHolder=0x121a89000) at nsWrapperCache.cpp:58
#4  0x000000010449f045 in nsDocument::Destroy (this=0x121a89000) at nsDocument.cpp:8948
#5  0x0000000106d5fbcb in nsDocumentViewer::Destroy (this=0x121b5dbc0) at nsDocumentViewer.cpp:1642
#6  0x0000000106d6943b in nsDocumentViewer::Show (this=0x121e64830) at nsDocumentViewer.cpp:1957
#7  0x0000000106d9bd55 in nsPresContext::EnsureVisible (this=0x121428800) at nsPresContext.cpp:2250
#8  0x0000000106dad0ff in PresShell::UnsuppressAndInvalidate (this=0x12257b800) at nsPresShell.cpp:3758
#9  0x0000000106da44da in PresShell::UnsuppressPainting (this=0x12257b800) at nsPresShell.cpp:3801

<bz> I think there's our buggy stack
<bz> We clear out the expando object
<bz> which is where the location prop lives
<bz> The first one may be sticking around because it got bfcached or something

Test case coming up
(Reporter)

Comment 1

2 years ago
Created attachment 8733872 [details]
Helper 1
(Reporter)

Comment 2

2 years ago
Created attachment 8733873 [details]
Helper 2
(Reporter)

Comment 3

2 years ago
Created attachment 8733874 [details]
Test
(Reporter)

Comment 4

2 years ago
Created attachment 8733875 [details]
Test
Attachment #8733874 - Attachment is obsolete: true
No longer blocks: 1251361
Depends on: 1251361
Is this fixed now?
Flags: needinfo?(Ms2ger)
Whiteboard: btpp-followup-2016-04-20
(Reporter)

Comment 6

2 years ago
Seems like it is.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(Ms2ger)
Resolution: --- → DUPLICATE
Duplicate of bug: 1251361
Whiteboard: btpp-followup-2016-04-20
You need to log in before you can comment on or make changes to this bug.