Browser not responsive while debugging events

RESOLVED WONTFIX

Status

defect
P2
normal
RESOLVED WONTFIX
3 years ago
10 months ago

People

(Reporter: maurya1985, Unassigned)

Tracking

48 Branch

Firefox Tracking Flags

(firefox48 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Posted file error.txt
Steps to reproduce:
1. Launch browser
2. Enable the "Browser Toolbox" (See https://developer.mozilla.org/en-US/docs/Tools/Browser_Toolbox)
3. Launch the "Browser Toolbox" from the "Web Developer" tools menu
4. Click "OK" on the "Incoming Connection" prompt
5. Navigate to the "Debugger" tab in the toolbox and wait for the the sources to be loaded
6. Click the "Expand panes" button on the toolbar
7. Select "Events" tab in the right-side pane
8. You'll now notice that the browser is now completely frozen. The toolbox would still be operational though.
9. To see the error, select the "Console" tab on the toolbox (see attachment for full error)
(Reporter)

Comment 1

3 years ago
Expected:
The events pane should list all DOM events that currently have listeners bound from the javascript code.

Actual Result:
Browser frozen with error displayed in the Console tab of the toolbox.
This is basic functionality that should just work. Marking this as p1.
Priority: -- → P1
Cannot repro. Likely an edge case with a specific configuration. Any chance of a gif/screencast of the problem?
Priority: P1 → P2
(Reporter)

Comment 4

3 years ago
Posted image Capture.PNG
James, here's the screenshot with the browser on the left side and the toolbox on the right. After opening the "Events" tab in the right side pane, my browser completely froze. An interesting thing to note (highlighted in red in the screenshot) is that the debugger seems to have hung while trying to open the events tab. You'll see that the "Click to resume" button appears. The "pause" button is expected in a cleaner scenario. Let me see if I can get a screencast as well.

Comment 5

3 years ago
Can you unfreeze the debugger by hitting F8? If so, then this might be a duplicate of bug 582613.
Flags: needinfo?(maurya1985)

Comment 6

3 years ago
Clearing needinfo since the original reporter doesn't seem to be available.
Flags: needinfo?(maurya1985)
(In reply to Jim Blandy :jimb from comment #6)
> Clearing needinfo since the original reporter doesn't seem to be available.

Should we mark the bug as wontfix, since James could not reproduce it, and the original reporter doesn't seems to be unavailable?

Comment 8

3 years ago
Yes, that's probably right. Maurya, feel free to re-open if you can help out.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
FWIW I tried to repro it again and could not :(

Updated

10 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.