Wrong height of table cell

RESOLVED WORKSFORME

Status

()

Core
Layout
P4
normal
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Peter Thomassen, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(6 attachments)

(Reporter)

Description

16 years ago
Hi,
I don't understand why the cell with the red background ist too high (20px
higher than it should be). The table should have a heigth of 100 percent - it
has 100% + 20px. IE and Opera do right, so I think it's a bug in Mozilla's
layout engine.

Please answer,
Peter

Comment 1

16 years ago
Peter, I can't seem to access the url you supplied.  Please check that you gave
the correct address.  You could alternatively attach the offending HTML file to
this bug report using
http://bugzilla.mozilla.org/attachment.cgi?bugid=125916&action=enter

Also, please let us know exactly which build you're seeing this bug in.

Comment 2

16 years ago
Created attachment 69918 [details]
scrrendump - mozilla

Build ID: 2002 02 05 03. Windows 2000.

The provided URL works for me.

However, I fail to realize why this bug should have severity level "major".
The layout differences between Mozilla and Opera 6 are minimal.
IE 5.5 seems to fail somewhat with the yello zig-zag to the left.

Comment 3

16 years ago
Created attachment 69919 [details]
screendump - opera 6

Comment 4

16 years ago
Created attachment 69920 [details]
screendump - ie 5.5

Comment 5

16 years ago
Correction: I meant that _Opera_ fails with the yellow zig-zag pattern.
(Reporter)

Comment 6

16 years ago
Hi,
I use Mozilla Build 2002020406.
I simply don't understand why there is this red region exists, and why the
iframe rises up to the cell on the right.

Severity: major. Why? It's easy:
http://bugzilla.mozilla.org/bug_status.html#severity says, minor means problems
with easy workarounds. I didn't find any workaround.

How to attach a screen dump?

Thanks,
Peter

Comment 7

16 years ago
i tried the page in ie 5.0, opera 5 , moz 0.9.8 and ns 4.79 NONE of those render
it right... do you have any screenshot of how you expect it to look like ?
(Reporter)

Comment 8

16 years ago
Hi,
yes, I have. On 17 o'clock GMT I'm going to post one here. I'm not at my work 
computer at the moment.

Bye,
Peter
(Reporter)

Comment 9

16 years ago
Created attachment 70131 [details]
IE6 - Windows XP

Hi,
that's my screen dump with IE6 under Windows XP Professional, both German. It
should be viewed in this way with every browser, but it doesn't ... ;-)
Mozilla only shows a wrong height of the menchened (?) cell ...

Bye,
Peter
(Reporter)

Updated

16 years ago
Target Milestone: --- → mozilla0.9.8
(Reporter)

Updated

16 years ago
Priority: -- → P2

Comment 10

16 years ago
you cant target for moz 0.9.8, thats over already, severity AINT major and its
confirmed.
seems to me like the javascript written iframe doesnt receive the required
height. gotta look into it further, smells like tech evang

Updated

16 years ago
Severity: major → normal
Priority: P2 → --
Target Milestone: mozilla0.9.8 → ---

Comment 11

16 years ago
I tried fooling around with the document.  It seems that the table is actually
being rendered at more than 100% height.  In fact, it looks like the top 2 rows
are getting the 100% height, and the bottom row is begin pushed off the bottom
of the page.  The <iframe/> appears to be getting the correct calculated height
and width.

Another thing I noticed was that changing the style on the <table/> from
table-layout:fixed to table-layout:auto made much of the red gap go away.  This
may be an issue with dimension calculations under the fixed table layout algorithm.

<aside>Peter -- I would warn you against mingling CSS sizing with a table-based
layout. CSS is meant to be a complete layout language in itself, and therefore
the correct behavior of mingling the two is largely undefined.  Either go all
CSS or all table-based, and you'll have much better luck.  It would also allow
you to  avoid using document.write() to generate your <iframe/>, thereby
improving accessibility.</aside>

Comment 12

16 years ago
Changing QA contact

QA Contact: petersen → amar

Updated

16 years ago
restoring testcase URL.

The testcase renders fine for me, Linux mozilla 2002-04-12-21.  Attaching
screenshot.
Created attachment 79111 [details]
Mozilla screenshot
(Reporter)

Comment 15

16 years ago
I've redesigned.

Bye,
Peter
Peter, is the source that showed the bug available anywhere?  It's very hard to
fix the bug based on screenshots of incorrect rendering without having the code
that caused the incorrect rendering...
(Reporter)

Comment 17

16 years ago
Hi,
no, I've deleted it some days before ... but here's a outline of the old design:

___________________________________________________________
|         |                                        |      |
|  Menu   |                                        |      |
|         |________________________________________|      |
|         | ______________________________________ |      |
|         | |                100%                | |      |
|         | |                                    | |      |
|         | | 1                                1 | |      |
|         | | 0                                0 | |      |
|         | | 0                                0 | |      |
|         | | %                                % | |      |
|         | |                                    | |      |
|         | |________________100%________________| |      |
|         |________________________________________|      |
|         |                                        |      |
|_________|________________________________________|______|

The first row and the second row with the iframe took 100% of the screen height,
but I had definded 100% for the whole table. If you didn't understand, write
again, but I think, if you know this and look on the screenshot, you will
understand.

Bye,
Peter
What is the thing labeled as having "100%" width and height in that drawing?  Is
the whole thing supposed to be one table (with the cells on left and right
having rowspans)?  

I spent half an hour today playing with various combinations of things that look
like you posted and being unable to reproduce this bug, so if you can provide
sufficient information to actually reproduce it, that would be nice....
(Reporter)

Comment 19

16 years ago
Hi,
sorry, I've forgotten ... but you could see it in the other screenshots :)
It's an iframe.

Bye,
Peter
Peter, that answers only one of my two questions.

Basically, I cannot reproduce this bug.  Any help in doing so is much
appreciated... Something as simple as a clear description of how the HTML was
structured would be nice.  Was there an outer table?  Were its width and height
set?  How many rows?  How many columns?  Any colspans/rowspans?  Is the bright
red in the screenshots the background of a table cell and the white an iframe?
(Reporter)

Comment 21

16 years ago
Hi,

> Was there an outer table?

Yes, haven't you seen the outline?

> Were its width and height set?

height:
body, html, the outer table (all 100%), the first and the third row.

width:
the outer table (100%), the first and the third column.

> How many rows?  How many columns?

3/3

> Any colspans/rowspans?

You can see it in the outline.

> Is the bright
red in the screenshots the background of a table cell and the white an iframe?

Yes, right. The red is the background of the cell which contains the iframe.

Bye,
Peter

Comment 22

16 years ago
Boris, I remember originally testing this bug, and have tried reconstructing the
testcase based on my memory.  I haven't been able to reproduce the buggy
behavior in recent builds (haven't tried grabbing an older build yet to compare).  

I can't be sure that my testcase is 100% identical to the original (can't attach
it now, it's on my box at home).  I'm betting, though, that the problems have
been fixed in the meantime.

I'll look at it more this evening, and will attach my reconstructed testcase.

Comment 23

16 years ago
Created attachment 80341 [details]
Testcase reconstructed from memory and descriptions in comments

Viewing this testcase in recent builds does not show any of the buggy behavior
described in comments or shown in the screenshots.  Please confirm that this
testcase is right, and resolve the bug accordingly.
(Reporter)

Comment 24

16 years ago
Hi,
yes, it's right so far. I didn't have an absolute position as you do, and I 
have removed the borders between the cells via CSS. The rest is like you have 
it now (ok, I used more CSS, you used more HTML attributes).

Bye,
Peter

Comment 25

16 years ago
So then, Peter, do you agree this bug no longer exists?
(Reporter)

Comment 26

16 years ago
Hi,
I don't know, but I think you're right.

Bye,
Peter

Comment 27

16 years ago
Reporter says WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.