crash in OOM | unknown | mozalloc_abort | mozalloc_handle_oom | moz_xmalloc | mozilla::dom::Event::Event

RESOLVED DUPLICATE of bug 1259512

Status

()

--
critical
RESOLVED DUPLICATE of bug 1259512
3 years ago
3 years ago

People

(Reporter: elan, Unassigned)

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s?, firefox48 affected)

Details

(crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-526e87cb-ee78-42e8-8763-088fc2160314.
=============================================================
(Reporter)

Comment 1

3 years ago
:overholt, can you get an assignee for this one?
Flags: needinfo?(overholt)

Comment 2

3 years ago
This is really just a random OOM.
My guess is that we crash in http://hg.mozilla.org/releases/mozilla-beta/annotate/fb3494d06dfb/dom/events/Event.cpp#l109

But we have infallible malloc by default, so I don't know what we could do to this. Except revert back to fallible malloc and null checks everywhere. We're not allocating anything huge here.

Erin, is this some common OOM issue, or just one among the others?
Flags: needinfo?(elancaster)

Comment 3

3 years ago
Hmm, my guess is that we're close to OOM already elsewhere, so some operation doesn't work and then we try to dispatch error event (looks we're trying to create an error event in at least in the reports I've looked at), but creating the event doesn't work since allocation memory fails and we crash safely.
Flags: needinfo?(elancaster)
Olli, is this WidgetEvent thing going to be a small allocation? If so, this is really just showing up because bug 1236108 hasn't been backported to beta. This should be "OOM | small" and fall into that bucket.
Depends on: 1236108
I do see one crash on 48 in a 3-15 build, so maybe the crash annotation isn't always working.

Comment 6

3 years ago
On 64 bit opt linux build
p sizeof(mozilla::WidgetEvent)
$1 = 96
Depends on: 1256541
It seems like there isn't much to be done here.
Flags: needinfo?(overholt) → needinfo?(elancaster)
This looks like a content-process OOM | small.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(elancaster)
Resolution: --- → DUPLICATE
Duplicate of bug: 1259512
This is probably just a red herring, but I did see 2 crash reports (out of many), where the timer thread was in the middle of allocation (via chunk_alloc_mmap) when the crash occurred:

https://crash-stats.mozilla.com/report/index/99f1a418-4511-487c-85b0-699d82160320
https://crash-stats.mozilla.com/report/index/8740027a-80dd-4db2-a391-749fc2160322
You need to log in before you can comment on or make changes to this bug.