Closed Bug 1259245 Opened 4 years ago Closed 4 years ago

Land version 1.2.3 of the Loop system add-on in mozilla-central

Categories

(Hello (Loop) :: Client, defect, P1)

defect

Tracking

(firefox48 fixed)

RESOLVED WONTFIX
mozilla48
Tracking Status
firefox48 --- fixed

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Whiteboard: [btpp-fix-now])

Attachments

(1 file)

This is the next update for Loop. Top-level changes:

- An e10s fix to make the add-on work better when web sharing is active (titles handled correctly, add-on marked as e10s compatible).
- Layout fixes to the invitation views.
- Fix an issue on non-linux platforms, e.g. FreeBSD where the Hello icon isn't displayed due to css not applying there.
https://hg.mozilla.org/integration/fx-team/rev/7b0bb5c3ab01ab5003c64d2c715742db93eb9fd1
Bug 1259245 - Land version 1.2.3 of the Loop system add-on in mozilla-central - code updates. rs=Standard8 for already reviewed code.
https://hg.mozilla.org/mozilla-central/rev/7b0bb5c3ab01
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
Comment on attachment 8734117 [details] [diff] [review]
Land version 1.2.3 of the Loop system add-on in mozilla-central - code updates. rs=Standard8 for already reviewed code.

Approval Request Comment
[Feature/regressing bug #]: Firefox Hello 1.2.3 roll-out
[User impact if declined]: Fixes css issues on Linux like systems (e.g. FreeBSD) where the Hello button doesn't get displayed properly; fixes an issue with layout on the invitation views that affects some locales; includes a fix for an e10s issue where an event keeps being fired.
[Describe test coverage new/current, TreeHerder]: The e10s fix has its own test that also runs in non-e10s mode.
[Risks and why]: Low, the css fixes are small and self contained. The e10s fix has its own tests.
[String/UUID change made/needed]: None
Attachment #8734117 - Flags: approval-mozilla-beta?
Attachment #8734117 - Flags: approval-mozilla-aurora?
Oh ill-timed approval request, you are ill-timed.

Backed out in https://hg.mozilla.org/mozilla-central/rev/d5f3da0cfe7c for very frequent 10.10 opt e10s mochitest-5 crashes like https://treeherder.mozilla.org/logviewer.html#?job_id=8211122&repo=fx-team

No idea what lunacy caused us to think that since it happened two out of three tries on your push it was just fine, and must have been caused by fairies flying by sprinking orange dust or something, but in fact it happened 10 out of 25 retriggers on your push, and 0 out of 25 on your parent.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This also caused leaks in other Linux bc tests and in Windows 7 debug M-e10s(dt1):
https://treeherder.mozilla.org/logviewer.html#?job_id=8210013&repo=fx-team
Comment on attachment 8734117 [details] [diff] [review]
Land version 1.2.3 of the Loop system add-on in mozilla-central - code updates. rs=Standard8 for already reviewed code.

Dropping approval requests. We'll have to drop the e10s fixes for this version (fwiw I think the e10s frame scripts are pretty broken with these results), and we'll do another release to fix the couple of small issues with the layout - I'll get that up tomorrow, since today is officially a day off for me.
Attachment #8734117 - Flags: approval-mozilla-beta?
Attachment #8734117 - Flags: approval-mozilla-aurora?
Blocks: 1260811
Per previous comment, we're dropping the e10s fixes from the release, and we've tagged a new version - 1.2.4 is about to go out in bug 1260811.
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.