Closed Bug 1259293 Opened 4 years ago Closed 2 years ago

Remove -wd4312 from dom/media/moz.build

Categories

(Core :: Audio/Video: Playback, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: gps, Assigned: gerald)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

-wd4312 was added to dom/media/moz.build in bug 1124033 as part of supporting VS2015. This bug tracks removing that workaround.

I'm not sure what warning this is masking. Should be easy enough to reproduce.
Depends on: 1124033
MSDN says:

This warning detects an attempt to assign a 32-bit value to a 64-bit pointer type, for example, casting a 32-bit int or long to a 64-bit pointer. This can be an unsafe conversion even for pointer values that fit in 32 bits when sign extension occurs.

https://msdn.microsoft.com/en-us/library/h97f4b9y.aspx
Gerald, can you take care of this?
Flags: needinfo?(gsquelart)
Priority: -- → P2
Strange, I thought this warning suppression had not landed.
I believe it was originally needed because of something in FileBlockCache.h, which was fixed in bug 1256533.
So it should be fine to remove -wd4312, I'll look into it.

The one in dom/canvas/moz.build is probably due to the same thing in FileBlockCache.h, so I'll see if I can remove it as well (currently tracked with bug 1259291).
Assignee: nobody → gsquelart
Depends on: 1256533
Flags: needinfo?(gsquelart)
See Also: → 1259291
Component: Audio/Video → Audio/Video: Playback
Bug 1257317 (media/webrtc/trunk/webrtc/base/criticalsection.h(59): warning C4312: 'reinterpret_cast': conversion from 'DWORD' to 'HANDLE' of greater size) prevents removing -wd4312 from dom/media/moz.build
Depends on: 1257317
Mass change P2 -> P3
Priority: P2 → P3
Comment on attachment 8932723 [details]
Bug 1259293 - Remove -wd4312 which was needed with VS2015 -

https://reviewboard.mozilla.org/r/203770/#review209264
Attachment #8932723 - Flags: review?(jwwang) → review+
Comment on attachment 8932723 [details]
Bug 1259293 - Remove -wd4312 which was needed with VS2015 -

https://reviewboard.mozilla.org/r/203770/#review209264
Thank you for the lightning-speed review, JW!
Pushed by gsquelart@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ba391f5870d
Remove -wd4312 which was needed with VS2015 - r=jwwang
https://hg.mozilla.org/mozilla-central/rev/0ba391f5870d
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.