Dragging Element to Canvas Broken in add-on, works fine with `firefox -app` & `xulrunner`.

RESOLVED WONTFIX

Status

()

Firefox
Extension Compatibility
RESOLVED WONTFIX
2 years ago
4 months ago

People

(Reporter: pavan.rikhi, Unassigned, NeedInfo)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
Firefox 45 has broken my plugin, Pencil Prototyping:
https://addons.mozilla.org/en-US/firefox/addon/pencil-prototyping/
https://github.com/prikhi/pencil/

When installed as a Firefox plugin, dragging elements from the left sidebar onto the canvas is broken. The element does not appear while the mouse is held down or when it is let go. The mouse cursor does not change from the "dragging but not dropable area" cursor to the "dragging and in dropable area" cursor.

When I tested it with the FFv44 release & the issue went away. I was once again able to drag elements into my canvas element. I didn't see any relevant or breaking changes in the FFv45 release notes.

When you run the `application.ini` directly with `firefox -app` or `xulrunner`, the issue goes away - even with FFv45.
(Reporter)

Updated

2 years ago
OS: Unspecified → All
Hardware: Unspecified → All

Comment 1

2 years ago
How does work your add-on? I installed it but I'm not able to add elements in the new document from the left pane, like a triangle or a rectangle.
Flags: needinfo?(pavan.rikhi)
(Reporter)

Comment 2

2 years ago
@Loic Please compare the plugin in both FFv44 & FFv45. You are able to add elements if you try it in FFv44.

Something in FFv45 has broken this & I saw no backwards-incompatible change documented in the release notes for FFv45.
Flags: needinfo?(pavan.rikhi)

Comment 3

2 years ago
I'm not speaking about 45 but, in general, I'm not able to use your add-on with 44 or older.
(Reporter)

Comment 4

2 years ago
Dragging works fine for me when Firefox is installed from the exe here:
https://ftp.mozilla.org/pub/firefox/releases/44.0/win64/en-US/

You can see so in this video: http://screencast.com/t/NSzyOnY5

Comment 5

2 years ago
I'm not able to drag and drop elements with old versions, the mouse cursor switches to the forbidden circle.
(Reporter)

Comment 6

2 years ago
In FFv44, I tried deleting my profile, creating a new one, installing the addon from AMO, & I was still able to drag & drop fine. Not sure why it isn't working for you, did you try with the FF installer I linked above, or nightly or something else?

Can you try unpacking the XPI and running the application.ini with `firefox -app`? The dropping should work there as well as w/ xulrunner. It is only broken when running as a Firefox plugin.

Comment 7

2 years ago
It's weird, it doesn't work with versions downloaded with Mozregression (http://mozilla.github.io/mozregression/). This tool is used to find regression range in nightly builds, and I used it with a custom profile and Pencil Prototyping installed.

In fact, I have to install the build to make your add-on work, that's sad. (because it makes regression hunting really long and painful) :/

Comment 8

2 years ago
After testing, drag and drop doesn't work in general with standalone versions (like http://ftp.mozilla.org/pub/firefox/nightly/2015/10/2015-10-02-03-02-04-mozilla-central/firefox-44.0a1.en-US.win32.zip), I have to install the executable.

Do you know some commdands to make your add-on work without installing the build?

Comment 9

2 years ago
You can test yourself.
Download a zip version from http://ftp.mozilla.org/pub/firefox/nightly/2015/10/2015-10-02-03-02-04-mozilla-central/ then unzip the folder and use the .exe with a custom profile.
(Reporter)

Comment 10

2 years ago
Someone in IRC tried that as well. They suggested that it may have been a long running issue in nightly that had finally gotten finished & merged in v45(I dunno - that seems like something that would live in it's own branch...). I think they tried back to v38 and did not getting it working with nightly builds.

I have the MinVersion as 38 but you should be able to go all the way back to 1.9.8 or so (going pre-38 just breaks some exporting - dragging should still work fine).

Comment 11

2 years ago
I tried with nightlies from 40 to 44 and drag and drop was broken. I installed 40, drag and drop works.

It's easy to test with this nightly 44 e.g.:
1) Installer version:
http://ftp.mozilla.org/pub/firefox/nightly/2015/10/2015-10-02-03-02-04-mozilla-central/firefox-44.0a1.en-US.win32.installer.exe
2) Standalone version:
http://ftp.mozilla.org/pub/firefox/nightly/2015/10/2015-10-02-03-02-04-mozilla-central/firefox-44.0a1.en-US.win32.zip

1) will work, 2) will not.
(Reporter)

Comment 12

2 years ago
So where do we go from here?

Comment 13

2 years ago
A solution is finding the regression rane manually by downloading the installer of nightlies between 44 and 45 and testing your add-on with a custom profile.
By dichotomy (divide the range by 2), you should find relatively fastly the day of the last good nightly and the day of the first bad nightly, this will provide a first pushlog.

The first nightly 45 appeared on 2015-10-29:
http://ftp.mozilla.org/pub/firefox/nightly/2015/10/2015-10-29-04-52-27-mozilla-central/

Comment 14

2 years ago
Can you do more testing to narrow down what exactly is broken? You're not using a regular canvas at all, you're using a custom XBL binding with a load of JS and not a <html:canvas> in sight. It would be really helpful if you could either get a reduced testcase that works with mozregression, or manually obtain a regression window. Otherwise this bug is not really actionable as-is.
Component: General → Extension Compatibility
Flags: needinfo?(pavan.rikhi)
Summary: Dragging Element to Canvas Broken in Plugin, Works Fine with `firefox -app` & `xulrunner`. → Dragging Element to Canvas Broken in add-on, works fine with `firefox -app` & `xulrunner`.
(Reporter)

Comment 15

2 years ago
I will do more digging but it's hard for me to find time at the moment.


Loic, the nightly installer you linked as working doesn't work for me:
http://ftp.mozilla.org/pub/firefox/nightly/2015/10/2015-10-02-03-02-04-mozilla-central/firefox-44.0a1.en-US.win32.installer.exe

I tried deleting my profile before uninstalling previous nightlies, then
installing Pencil after launching the nightly for the first time. Is there
something I'm missing to get it working?

Updated

a year ago
Duplicate of this bug: 1342253
Mass-closing old Extension Compatibility bugs that relate to legacy add-ons or NPAPI plug-ins. If you think this bug is still valid, please reopen or comment.

Sorry for the bug spam, and happy Friday!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.