"See more activity" button is displayed when one website is available in history

VERIFIED FIXED

Status

()

Firefox
Activity Streams: Timeline
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: VladB, Unassigned)

Tracking

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(firefox48 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8734318 [details]
see more activity button

[Affected versions]:
- Firefox 45.0 and up
- Activity Stream 1.0.4

[Affected Platforms]:
- All Windows
- All Mac OS
- All Linux

[Prerequisites]:
- Latest Activity Stream add-on version (1.0.4) was previously installed on a profile.
- There is no history for the profile used.

[Steps to reproduce]:
1. Start Firefox browser with the profile where Activity Stream add-on was previously installed.
2. Visit a website (e.g. 9gag.com)
3. After the page is loaded click on "Activity Stream" button from browser toolbar.

[Expected results]:
One website is displayed in the Timeline.
There is no "See more activity" button.

[Actual results]:
"See more activity" button is displayed even if there are no other websites that can be loaded in Timeline.
Filed in GitHub as https://github.com/mozilla/activity-streams/issues/454
will be fixed by a fix to bug 1262169
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1262169
(Reporter)

Comment 3

2 years ago
This issue was verified on Activity Stream v1.0.14-dev and it is reproducible.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

2 years ago
Implemented infinite scroll.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

2 years ago
Fixed by implementing infinite scroll functionality. Items that are not in viewport are displayed when scroll action is performed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.