[PREF MIGRATION] migrate the "remember password pref"

VERIFIED FIXED in M11

Status

P3
normal
VERIFIED FIXED
20 years ago
11 years ago

People

(Reporter: sspitzer, Assigned: sspitzer)

Tracking

Trunk
PowerPC
All

Firefox Tracking Flags

(Not tracked)

Details

for 4.x pop and 4.x imap servers.

I've got this fix in my tree. as soon as the tree goes green, I'll check it in.
Status: NEW → ASSIGNED
Target Milestone: M10
marking m10.
accepting
Assignee: phil → sspitzer
Status: ASSIGNED → NEW
assign to me.
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
fixed.  now this pref gets migrated for pop and imap 4.x servers.

Comment 4

20 years ago
As far as I can tell from NT 4.0 so far, this pref migrates only to prefs.js as
a 4.x style pref line which doesn't specify server number (like
server.server1.remember_password).  There is no 5.0 style prefs.js line, and
after migration password is not remembered even after several successful
authentications to server over sessions.  The Account Setup UI does indeed
display an enabled state/checkmark for the pref, but it doesn't appear to work
for either POP or IMAP.

I have gotten remember password to work if enabling it for the first time in
seamonkey, so I know it does work at some level.  I have some more testing to do
before I change the status of this bug report. Just wanted to report my findings
so far.

Updated

20 years ago
Status: RESOLVED → REOPENED

Updated

20 years ago
Resolution: FIXED → ---

Comment 5

20 years ago
Reopening this.
Using 10-04m11 build (tested mac and nt 4.0)
Here's what happens with migration of remember password pref:

1.  IMAP: If you haven't set remember password in 4.x, the seamonkey migrated
prefs.js file shows one 4.x style line (doesn't specify server id) in the
seamonkey prefs.js file: mail.imap.server.nsmail-1.remember_password, false
2.  POP:  If you haven't set remember password in 4.x, the seamonkey migrated
prefs.js file shows no remember password pref line at all.
3.  IMAP:  If you did remember password in 4.x and migrate, the seamoney
prefs.js file shows a 4.x style remember password == true, but doesn't set 5.0
line(s). Try to get mail, you're asked for password. Pref is not set properly
for 5.0.
4.  POP:  If you did remember password in 4.x and migrate, the seamoney prefs.js
file shows a 4.x style remember password == true, but doesn't set 5.0 line(s).
Try to get mail, you're asked for password. Pref is not set properly for 5.0.
Status: REOPENED → ASSIGNED
Target Milestone: M10 → M11
moving to m11.

accepting.

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago19 years ago
Resolution: --- → FIXED

Comment 7

19 years ago
sspitzer sez fixed. laurel?

Comment 8

19 years ago
Using 1999-11-01-08m11 on NT 4.0:

Well, now the pref mail.server.server1.remember_password is set to true upon
migration when the password was remembered in 4.x.  However, there is no entry
in prefs (5.0 style) for the password itself, so the user must provide the
password again when using 5.0 for the first time.  This is true of both IMAP
and  POP.

So, technically, yes we are migrating the pref. But it doesn't work first time
out in 5.0.

Will check other platforms...

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: FIXED → ---

Comment 9

19 years ago
Same on linux.
Can't migrate on MAC.

Reopening...

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 10

19 years ago
Hi Laurel, this is actually the intended behavior. The password in 4.x is
encrypted

using non open source code. We can't decrypt it in 5.0. So we have to
force the user to re-enter there password after migrating with remember
password for the first time.

So remember_password should get migrated. But you should never see the 4.x
password itself get migrated. We'll ask the user for this password the first
time we need it and then we'll remember it and write it out to prefs.

Re-closing.

Comment 11

19 years ago
OK. Verified on NT 4.0 and linux 6.0
Someday when Mac migration is fixed, I'll verify it on mac.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 12

19 years ago
OK using 1999-11-04-08m11 commercial build Mac OS 8.5.1
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.