Browser history not deleted when I exit Firefox mobile Nightly

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
2 years ago
22 days ago

People

(Reporter: lolbrol, Unassigned)

Tracking

48 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160323030400
Firefox for Android

Steps to reproduce:

I use the "delete private data when exiting"(settings--> privacy)
After some browsing I always exit Firefox, but since a few day I noticed that firefox stopped deleting my browser history after I exit.



Actual results:

My browse history is not deleted.


Expected results:

My browse history should be gone.
(Reporter)

Updated

2 years ago
OS: Unspecified → Android
Hardware: Unspecified → ARM

Updated

2 years ago
Component: Untriaged → General
(Reporter)

Updated

2 years ago
Component: General → General
Product: Firefox → Firefox for Android
Can you please tell me which device and OS are you using? And also on which Firefox version you reproduce this issue.
Do you have "Browsing history" checked in Settings -> Privacy -> Clear private data on exit ?
When checking on option from  "Clear private data on exit", a "Quit" button is displayed in the Menu.
Tapping the "Quit" button will delete the browsing history.
If you choose to close Firefox by swiping it from the Task manager, then it won't delete the browsing history.
Which method did you try?
Flags: needinfo?(zoelskoeltem03_05_)
(Reporter)

Comment 2

2 years ago
Can you please tell me which device and OS are you using? And also on which Firefox version you reproduce this issue.
Elephone p6000 pro, android 5.1, Firefox 48.0a1(2016-03-25)

Do you have "Browsing history" checked in Settings -> Privacy -> Clear private data on exit ?
Yes, I selected browsing history, search history, downloads, form history and buffer. (Screenshot in Dutch http://i.imgur.com/VDNlbtr.png)

 
When checking on option from  "Clear private data on exit", a "Quit" button is displayed in the Menu.
Tapping the "Quit" button will delete the browsing history.
If you choose to close Firefox by swiping it from the Task manager, then it won't delete the browsing history.
Which method did you try?

I use always the exit option in the pop-up menu of Firefox. I don't close Firefox by swiping it from the Task manager.
Flags: needinfo?(zoelskoeltem03_05_)

Comment 3

22 days ago
Couldn't reproduce on latest Nightly build with a Samsung Galaxy S8+ (Android 8.0.0) so I will close this bug as worksforme. If this is still reproducing for you, please reopen it and mention what device and build you used.

Thanks,
Andrei
Status: UNCONFIRMED → RESOLVED
Last Resolved: 22 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.