If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Forcing WARP gives lots of rendering artifacts on Windows 10

RESOLVED WONTFIX

Status

()

Core
Graphics: Layers
RESOLVED WONTFIX
2 years ago
a year ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gfx-noted)

(Reporter)

Description

2 years ago
Setting layers.d3d11.force-warp to true on Windows 10 gives all kinds of rendering artifacts.
(Reporter)

Updated

2 years ago
Keywords: regression, regressionwindow-wanted
Hi, 

I ran mozregression to try and find a window for this issue, but since the last know good build is from 2014-12-15, the taskclusters for inbound no longer exist.

Last good revision: f14dcd1c8c0b (2014-12-15)
First bad revision: b836016d82b5 (2014-12-16)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f14dcd1c8c0b&tochange=b836016d82b5
Out of this pushlog the only thing that stands out to me is Bug 1088414.

Thanks,
Cipri
Keywords: regressionwindow-wanted
(In reply to Jeff Muizelaar [:jrmuizel] from comment #0)
> Setting layers.d3d11.force-warp to true on Windows 10 gives all kinds of
> rendering artifacts.

Are you remembering to also disable Direct2D? WARP with D2D isn't really a tested config.
Flags: needinfo?(jmuizelaar)
Whiteboard: gfx-noted
(Reporter)

Comment 3

2 years ago
I forgot.
Flags: needinfo?(jmuizelaar)
Setting gfx.direct2d.disabled to true does seem to make the issue go away.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
Keywords: regression
You need to log in before you can comment on or make changes to this bug.