Template strings falsify console line numbers

RESOLVED DUPLICATE of bug 1253847

Status

()

RESOLVED DUPLICATE of bug 1253847
3 years ago
3 years ago

People

(Reporter: christian.schmidt221, Unassigned)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822

Steps to reproduce:

1) Run code that includes a multi-line template string
2) Log something in console \ Trigger error after the template string
3) Note line number displayed in console

e.g:
_________________________
var a = `line1    // Counted once (-> 1)
line2                // Counted twice (-> 3)
line3                // Counted twice (-> 5)
line4`;             // Counted twice (-> 7)
asdf                // Error is actually here (Line 5)


// Error message points to this line ( Line 8 )


Actual results:

Line numbers displayed in console are wrong, because lines that contain template strings (except the first template string line) are beeing counted twice.


Expected results:

Lines containing template strings should only be counted a one line each.
Component: Untriaged → JavaScript Engine
Product: Firefox → Core

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1253847
You need to log in before you can comment on or make changes to this bug.