Remember and restore link focus after forward/back

VERIFIED DUPLICATE of bug 36539

Status

()

defect
VERIFIED DUPLICATE of bug 36539
17 years ago
a month ago

People

(Reporter: liblit, Assigned: bryner)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

(Reporter)

Description

17 years ago
One can use <Tab> to focus on a particular link in a page, then <Enter> to
follow that link.  However, if one later uses Back to return to that page, the
link focus is gone.  This can make keyboard-based surfing tedious, especially if
one's intention was to follow a link, back up, then follow the next link in the
<Tab> sequence.

Mozilla should remember which link had focus, and restore that focus when
Forward or Back redisplays the page.  Presumably the logic for doing this would
be similar to the existing logic for remembering and restoring pages' scroll
positions.

Comment 1

17 years ago
I know htis is a dup, just don't of which
Assignee: aaronl → bryner
Whiteboard: DUPEME

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 36539 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Component: Keyboard: Navigation → User events and focus handling
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.