input with datalist dropdown picks wrong item

RESOLVED DUPLICATE of bug 1242208

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 1242208
2 years ago
2 years ago

People

(Reporter: zash, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8734722 [details]
input-list.html

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160319015032

Steps to reproduce:

An issue tracker with an <input> element with associated <datalist> for adding tags.
Having used this several times to set tags, Firefox remembers old items used.
Type some letters to narrow the list to a single item and click it.


Actual results:

A different item from the <datalist> is inserted set as value of the <input> element.

Similar to bug 1180827.


Expected results:

The value of the <input> element should be set to the selected item from the <datalist>

Updated

2 years ago
Component: Untriaged → Layout: Form Controls
Product: Firefox → Core
Hi Zash,

Could you provide some more detailed steps to reproduce? I'm not seeing problems on Firefox 45.0.1. or Nightly on OS X. Could you also test in Safe Mode[1] or with a new profile? 

Could you also flip the pref formfill.debug in about:config to true and watch the output in the Browser Console[2] when you have the problem. Attaching that log with context around what you're doing would help as I wonder if the problem is bad autocomplete cache invalidation. The following log lines which may look like a problem probably aren't related:
* TypeError: this._recipeManager is null (bug 1167872)
* The character encoding of the HTML document was not declared…

[1] https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode
[2] https://developer.mozilla.org/en-US/docs/Tools/Browser_Console
Flags: needinfo?(zash)
(Reporter)

Comment 2

2 years ago
Created attachment 8734756 [details]
formfill log

So, with a clean profile and formfill.debug = true, I have the attached (to the initial report) input-list.html on a site of mine.

First I write "Lorem-Ipsum" and submit the form.
Then I write "star", and pick "Status-Started" from the suggested list, but I get a different value in the field, "Status-WontFix"
Flags: needinfo?(zash)
(Reporter)

Comment 3

2 years ago
For the record, this is Firefox 45 from mozilla.debian.net on Debian Jessie

~$ apt-cache policy firefox
firefox:
  Installed: 45.0.1-1~bpo80+1
  Candidate: 45.0.1-1~bpo80+1
  Version table:
 *** 45.0.1-1~bpo80+1 0
        500 http://mozilla.debian.net/ jessie-backports/firefox-release amd64 Packages
        100 /var/lib/dpkg/status

Comment 4

2 years ago
Could you test with the official Linux version from Mozilla?
https://www.mozilla.org/en-US/firefox/all/
Flags: needinfo?(zash)
(Reporter)

Comment 5

2 years ago
Created attachment 8735166 [details]
another formfill log, annotated

Reproduced with official release from tarball
Flags: needinfo?(zash)

Comment 6

2 years ago
It's fixed in 47+.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1242208
You need to log in before you can comment on or make changes to this bug.