TEST-UNEXPECTED-FAIL | test-plugin-blocked.js | test-plugin-blocked.js::test_blocklisted_plugin_notification

RESOLVED DUPLICATE of bug 1259815

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 1259815
2 years ago
2 years ago

People

(Reporter: ISHIKAWA, Chiaki, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

2 years ago
I see a couple of errors originating from nsBlocklistService.js
when I ran   |make mozill| test of C-C TB locally.

These are very new. I have never seen this before (in the last few years of testing).

case-1 :
SUMMARY-UNEXPECTED-FAIL | test-plugin-blocked.js | test-plugin-blocked.js::test_blocklisted_plugin_notification
  EXCEPTION: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref]
    at: nonesuch line 632
       Blocklist.prototype.notify nsBlocklistService.js:632 9
       updateBlocklist test-content-tab-helpers.js:426 3
       setAndUpdateBlocklist test-content-tab-helpers.js:434 3
       test_blocklisted_plugin_notification test-plugin-blocked.js:68 3
       Runner.prototype.wrapper frame.js:585 9
       Runner.prototype._runTestModule frame.js:655 9
       Runner.prototype.runTestModule frame.js:701 3
       Runner.prototype.runTestDirectory frame.js:525 7
       runTestDirectory frame.js:707 3
       Bridge.prototype._execFunction server.js:179 10
       Bridge.prototype.execFunction server.js:183 16
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3

case-2:
Summary-UNEXPECTED-FAIL | test-plugin-outdated.js | test-plugin-outdated.js::test_outdated_plugin_notification
  EXCEPTION: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref]
    at: nonesuch line 632
       Blocklist.prototype.notify nsBlocklistService.js:632 9
       updateBlocklist test-content-tab-helpers.js:426 3
       setAndUpdateBlocklist test-content-tab-helpers.js:434 3
       test_outdated_plugin_notification test-plugin-outdated.js:58 3
       Runner.prototype.wrapper frame.js:585 9
       Runner.prototype._runTestModule frame.js:655 9
       Runner.prototype.runTestModule frame.js:701 3
       Runner.prototype.runTestDirectory frame.js:525 7
       runTestDirectory frame.js:707 3
       Bridge.prototype._execFunction server.js:179 10
       Bridge.prototype.execFunction server.js:183 16
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3

In any case, being able to build and test C-C TB after a couple of weeks is very nice. I would like to thank everybody who have fixed the related issues!

Comment 1

2 years ago
See bug 1247662 + bug 1248557.
Summary: C-C mozmill test: nsBlocklistService.js throws exception? → TEST-UNEXPECTED-FAIL | test-plugin-blocked.js | test-plugin-blocked.js::test_blocklisted_plugin_notification

Comment 2

2 years ago
Created attachment 8734882 [details] [diff] [review]
bug1259774_kinto_pref.patch

Port http://hg.mozilla.org/mozilla-central/diff/8ed64dabb118/browser/app/profile/firefox.js
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #8734882 - Flags: review?(mozilla)

Updated

2 years ago
Attachment #8734882 - Attachment is obsolete: true
Attachment #8734882 - Flags: review?(mozilla)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1259815

Comment 4

2 years ago
So sorry about this, great minds think alike. Anyway, my patch was nicer since it had capitalisation and a full stop in the comment ;-)

Updated

2 years ago
Assignee: mkmelin+mozilla → nobody
You need to log in before you can comment on or make changes to this bug.