Doorhanger back arrow icon should not respond to right click

RESOLVED DUPLICATE of bug 1204825

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 1204825
2 years ago
2 years ago

People

(Reporter: Muktasib Un Nur, Unassigned)

Tracking

Trunk
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8734837 [details]
Left click works, right click doesn't

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160322075646

Steps to reproduce:

1. Go to any site. E.g. : https://www.mozilla.org/en-US/?v=b
2. Left click on "Site Information".
3. Left click on doorhanger arrow icon.
4. Now right click on Doorhanger back arrow icon.


Actual results:

Doorhanger returns to its previous window by responding to right click.
(See the screenshots)


Expected results:

The back arrow should have responded to only left click, not both left & right click. No other icons in Firefox respond to right click. So this icon also should not.
This is for nightly. But the bug is present in other branches.
(Reporter)

Comment 1

2 years ago
Created attachment 8734838 [details]
Left & Right both click works
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86_64

Updated

2 years ago
Component: Untriaged → Location Bar

Comment 2

2 years ago
I can confirm the behaviour described is present in Firefox stable (45.0.1). There don't appear to be any adverse effects though - is this a bug?

Updated

2 years ago
Blocks: 1170759
Component: Location Bar → General

Updated

2 years ago
Summary: Doorhanger back arrow icon should not respond to right click → [Control Center] Doorhanger back arrow icon should not respond to right click

Updated

2 years ago
Whiteboard: [fxprivacy] [triage]
The hamburger menu panel has the same behavior (e.h. history, synced tabs), so it's a broader panel issue (assuming we consider this a bug).
Component: General → Toolbars and Customization
Summary: [Control Center] Doorhanger back arrow icon should not respond to right click → Doorhanger back arrow icon should not respond to right click
Whiteboard: [fxprivacy] [triage]
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1204825
You need to log in before you can comment on or make changes to this bug.