Closed Bug 125983 Opened 18 years ago Closed 17 years ago

alt text of images with no SRC attribute is not visible without height/width

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Future

People

(Reporter: BenB, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: access, testcase)

Attachments

(1 file)

Load the following HTML in your browser:
<a href="foobar"><img alt="This text should appear, so you know there was an
image and what it was supposed to mean"></a>

Expected result:
All alt text is readable.

Actual result:
You see a small dot instead of the image.
Attached file Reduced testcase
I consider this being dataloss in the rendering.
This is very visible with bug 108153.
Keywords: mozilla1.0
Keywords: testcase
This used to work
Keywords: regression
Marking nsbeta1+
Keywords: nsbeta1+
Target Milestone: --- → mozilla1.0
When did this break!?!  I know this worked when I changed the quirks-mode
handling of alt text - I tested the heck out of it then.

Can anyone try to narrow down the date of regression?
Status: NEW → ASSIGNED
Keywords: nsbeta1+
I am seeing this on an image with width and height. The HTML code used is:
<p style="margin-top: 0px; margin-bottom: 5px;"><img src="/images/title.gif"
width="450" height="93" alt="LemNet.com Logo" style="margin-top: 0px;
padding-top: 0px; border: 0px;"></p>

and you can see it online at http://www.lemnet.blinksworld.com/ (it is the logo
in the very top left)
Is this a dupe of 62046? 

"ALT text of <img> element isn't displayed when "Do not load any images" in
Preferences is checked.

It is displayed if the <img> element has HEIGHT and WIDTH attributes."

I have images disabled, but the image in question has width and height attributes.
WIN 98, build 2002021915

The cause of this seems to be the lack of src="somethign". What I am seeing::

<p><img alt="alt text"></p> displays nothing.
<p><img src="" alt="alt text"></p> displays nothing.
<p><img src="broken_link.jpg" alt="alt text"></p> displays the text.
<p><img width="100" height="100" alt="alt text"></p> displays the text.

Tim.
Changing QA contact
QA Contact: petersen → moied
Priority: -- → P3
Marking nsbeta1+
Keywords: nsbeta1+
Images missing the mandatory src attribute have never shown the alt text...
that's a long standing bug. (Well, I guess it's a bug. Hard to say, since it's
invalid and thus not covered by the specs.)
Keywords: regression
> Images missing the mandatory src attribute

The testcase does have a src attribute (so it's a legal document), just that
it's empty.
Ok, that's a slightly more serious bug. I guess it means use the current page as
the image? Or something?

Still, that has never worked, so it's not a regression.
Sorry, this is not a big problem.  IMG with no SRC attribute, or an empty SRC
attribute, will not cause alt text to be displayed.  If width and height are
specified, then the alt text will be displayed.

In general usage, the src attribute on the IMG is specified, so this is more or
less academic.

clearing nsbeta1+ and moving to future.
Severity: major → normal
Keywords: nsbeta1+nsbeta1
Summary: alt text of unloadable images not visible without height/width → alt text of images with no SRC attribute is not visible without height/width
Target Milestone: mozilla1.0 → Future
> this is more or less academic.

No, it is not academic with bug 108153, where I remove the source attibute to
guard against bug 28327.
nsbeta1- based on comment #14
Keywords: nsbeta1nsbeta1-
I'm not sure if this is the same bug, but the alternate text for images very
rarely shows up in a tooltip, and I can't pinpoint exactly which images show the
alternate text and which don't. For example, load <http://www.aripollak.com>.
That big "aripollak.com" graphic on top is assigned ALT="aripollak.com".
However, that text shows up neither in a tooltip or in the image properties. The
banner ad below the title, however, shows the alternate text in both a tooltip
and the image properties. 
I have seen other pages which have linked images with alternate text, but the
text never shows up.
No, it is not the same bug, in fact no bug at all, but a FAQ.
Ari, what you're looking for is title="...", that's what you've got in your
source for the banner. alt="..." only is the alternative text which gets shown
when the image isn't loaded. The title is what get's displayed as tooltip.
It is the only bug I found regarding my problem...

I have a home page (http://cgi-bin.spaceports.com/~species6) which does not
display any alt=... 

here an example:

<img src="../pics/homep_0.gif" name="Handy Shopper" alt="Home page"
 border="0" height="40" width="36">

when moving the mouse cursor over the picture, I expect to see the alt=. it
works fine under NetScape 4.75.

is it not supported by Mozilla 1.1, or does I have some faulty settings in my
browser?
Jam, please see the comment right above yours. This is FAQ, search on the net.
On Mozilla 1.0.1, Linux. I don't see ALT text for quirks pages with
image loading disabled. Is that this bug getting worse, or a different
bug? To see what I mean, disable image loading and go to...

http://open-beos.sourceforge.net/news.php

Why is there no alt text shown for the left side menu? Instead there seem to be
tiny invisible place holders.

If I've found the wrong bug please point me to the right one. All the other ones
I looked in were full of users asking for ALT tooltips or moon cheese or whatever.
Re: comment 22
This issue is bug 180620.
-> Layout again
Assignee: attinasi → other
Blocks: alttext
Status: ASSIGNED → NEW
QA Contact: moied → ian
Bug 83774 fixed this.
Status: NEW → RESOLVED
Closed: 17 years ago
Depends on: 83774
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.