no access to about:addons page

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: ned-flenders, Unassigned)

Tracking

45 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160315153207

Steps to reproduce:

installed pkrss addon (since thfirefox has unfortunately no native rss support!)
addon required a firefox restart



Actual results:

after restart there is no access to the addon page (about:addons)
Addon page is visible for 1 second then the following page is schown:
about:neterror?e=unknownProtocolFound&u=rdf:#$32c4e
this errorpage says (translated to english): "Address not recognized"


Expected results:

about:addon page should load normally to delete that rss addon
(Reporter)

Updated

3 years ago
OS: Unspecified → Android
Hardware: Unspecified → ARM
(Reporter)

Comment 1

3 years ago
is it pollible to fix this without a complete firefox reset? I would like to avoid reinstalling firefox.
is it possible to start without addons, or to delete an addon without the about:addons page, or thomething else?
(Reporter)

Comment 2

3 years ago
sorry for the spelling errors... :-(
I cannot reproduce this with "Stylish" add-on which also needs restarts.
I can reproduce with "Pkrss" add-on:
1. Install it
2. Restart Firefox
=> ADD-ONS page with "pkrss" is displayed
=> but if I go to Tools > Add-ons, or I enter manually about:addons, "The address wasn't understood" page is displayed.
I can reproduce this on all branches
(Reporter)

Comment 4

3 years ago
Thanks for testing.
Now we need a fix without loosing firefox´s personal data and settings. :-)
And other users should be warned not to install pkrss.
Could this be a safety issue or virus? Or is it just a simple bug?
Flags: needinfo?(margaret.leibovic)
(Reporter)

Comment 5

3 years ago
I found out that there is a button "restart without addons"(translated) in "about:support" page.
This button does nothing...
Could somebody test if the button is working generally?

Comment 6

3 years ago
I can't reproduce this bug on my local build. Is it possible the add-on was updated? It seems like this is an issue with the add-on.

(In reply to Frank from comment #5)
> I found out that there is a button "restart without addons"(translated) in
> "about:support" page.
> This button does nothing...
> Could somebody test if the button is working generally?

This button isn't supported on mobile.
Flags: needinfo?(margaret.leibovic) → needinfo?(teodora.vermesan)
Summary: no access to about:addon page → no access to about:addons page
I cannot reproduce it anymore on latest Nightly (2016-04-06) using Samsung S6 Edge (Android 5.1.1)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(teodora.vermesan)
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

3 years ago
OK thanks
I will simply wait until the next FF update arrives and hopefully the problem will disappear...

Just for your information:
The addon was not updated since 2013 and its only valid for firefox versions 10-26. That may be the reason why it doesnt work with newer firefox but it shouldn't be the reason why the addon page is completely blocked.
(Reporter)

Comment 9

2 years ago
small update: I had to reset FF to remove the problematic addon. Updating to a new version doesn´t solve that. Very annoying. An now I have another problem with addons: some of them dowssnt show me the settings anymore - but thats a different bug...
You need to log in before you can comment on or make changes to this bug.