extreme screen tearing on a long page

RESOLVED FIXED

Status

()

Core
Graphics: Layers
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: akavel, Unassigned)

Tracking

45 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(firefox45- wontfix, firefox46- wontfix, firefox47- fixed, firefox48 fixed, firefox-esr38 unaffected, firefox-esr45- wontfix)

Details

(Whiteboard: gfx-noted, URL)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160315153207

Steps to reproduce:

I've browsed to http://business-programming.com/business_programming.html#section-17 and then started scrolling the page to continue reading from that point. 


Actual results:

 The main contents of the page often does not scroll, and only a small stripe (a few pixels high) at the top of the page does scroll. I've tested it on at least 2 computers: 

1) Windows 10; Fx 45.0.1; GPU is Intel HD 515. 

2) Windows 10; Fx 44.0.2; dual GPU, Intel HD 4600 is the base one. No plugins.

On (1), after I disabled GPU acceleration & smooth scrolling, the effect seems much less pronounced (see the attached video). I'll try to submit a video done with normal settings later too; it is much worse (that's why I disabled the acceleration), makes it impossible to read the page.


Expected results:

Full page contents should be scrolling properly.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1209100

Comment 2

2 years ago
Sorry wrong bug.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

2 years ago
the movie recording I made proved too big for attachment, so I've put it on Dropbox at: https://www.dropbox.com/s/2sahoybwzi9863v/tearing.mp4?dl=0

Comment 4

2 years ago
Fixed in Nightly by bug 1209100:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6b034852b39fb66515bd80027ee5ab688a9ed60f&tochange=4c254ac91a0e4a99d75c6ab90a3e8ce4853aa925
Status: REOPENED → NEW
status-firefox45: --- → affected
status-firefox46: --- → affected
status-firefox47: --- → affected
status-firefox48: --- → fixed
status-firefox-esr38: --- → unaffected
status-firefox-esr45: --- → affected
tracking-firefox45: --- → ?
tracking-firefox46: --- → ?
tracking-firefox47: --- → ?
tracking-firefox-esr45: --- → ?
Depends on: 1209100
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
(Reporter)

Comment 5

2 years ago
@Alice0775, is your "Fixed in Nightly" comment again "Sorry wrong bug"? Or is it this time meant to refer to the bug I reported? TIA

Comment 6

2 years ago
Appearances of this bug is different that reported in bug 1209100.
So, I cannot say that this is exactly duplication of bug 1209100.
(Reporter)

Comment 7

2 years ago
I've uploaded the second video on Drop box at: https://www.dropbox.com/s/zr6ypz73dvkygok/strong%20tearing.mp4?dl=0 It shows behavior with GPU acceleration & smooth scrolling enabled back.
(Reporter)

Updated

2 years ago

Updated

2 years ago
Component: Untriaged → Graphics: Layers
Product: Firefox → Core
(Reporter)

Comment 8

2 years ago
Oook; so I've downloaded the 48 Nightly, and my issue seems indeed not to show up anymore too! I've only tested for a short while, but it looked much more stable, didn't see any hints of the bad behavior, while on current they show up quite fast. So, from my side, I suppose you can mark it resolved in 48 or something. Thanks, that was fast! ;)
Hmm, may not be an exact duplicate but maybe it was fixed by the backout in 1209100?  Markus do you think so?
Flags: needinfo?(mstange)
Too late for a fix for beta 46. We could still potentially uplift to 47.
status-firefox45: affected → wontfix
status-firefox46: affected → wontfix
tracking-firefox46: ? → -
Status: NEW → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
Whiteboard: gfx-noted
tracking-firefox45: ? → -
status-firefox-esr45: affected → wontfix
tracking-firefox-esr45: ? → -
As per comment 4, this issue is fixed by bug 1209100. Updating status Fx47 to reflect that.
status-firefox47: affected → fixed
tracking-firefox47: ? → -
Yes, this was fixed by the backout in bug 1209100.
Flags: needinfo?(mstange)
You need to log in before you can comment on or make changes to this bug.