Closed Bug 1260035 Opened 4 years ago Closed 4 years ago

Disable text encoding menu when no message displayed.

Categories

(SeaMonkey :: MailNews: General, defect)

defect
Not set

Tracking

(seamonkey2.42 fixed, seamonkey2.43 fixed, seamonkey2.44 fixed, seamonkey2.46 fixed)

RESOLVED FIXED
seamonkey2.45
Tracking Status
seamonkey2.42 --- fixed
seamonkey2.43 --- fixed
seamonkey2.44 --- fixed
seamonkey2.46 --- fixed

People

(Reporter: philip.chee, Assigned: frg)

References

Details

(Keywords: regression, Whiteboard: [leave open for branches])

Attachments

(1 file, 2 obsolete files)

See:
Bug 1235294 - Text Encoding menu disabled when charset not supported
Bug 1244430 - View->Text encoding produces exception with nsIStringBundle.GetStringFromName
https://hg.mozilla.org/comm-central/rev/2a6797a9c8aa
https://hg.mozilla.org/comm-central/rev/d468c5939d66
patch without whitespace cleanup
Attachment #8735296 - Flags: review?(philip.chee)
patch with whitespace cleanup. If too much I will open another bug for the ws parts.
Attachment #8735297 - Flags: review?(philip.chee)
Tested on Windows 7 en-US build VS2015 x64

User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0 SeaMonkey/2.45a1
Assignee: nobody → frgrahl
Revised patch. Further proof that you can bungle a one liner.
Attachment #8735296 - Attachment is obsolete: true
Attachment #8735297 - Attachment is obsolete: true
Attachment #8735296 - Flags: review?(philip.chee)
Attachment #8735297 - Flags: review?(philip.chee)
Attachment #8735308 - Flags: review?(philip.chee)
Comment on attachment 8735308 [details] [diff] [review]
1260035-text-encoding-disable-V2.patch

r=me
Attachment #8735308 - Flags: review?(philip.chee) → review+
Keywords: checkin-needed
http://hg.mozilla.org/comm-central/rev/9499eb58d87c
Status: NEW → ASSIGNED
Keywords: checkin-needed
Whiteboard: [leave open for branches]
Target Milestone: --- → seamonkey2.45
Comment on attachment 8735308 [details] [diff] [review]
1260035-text-encoding-disable-V2.patch

[Approval Request Comment]
Regression caused by (bug #): N/A
User impact if declined: Users cannot change text encoding if character set of mail message is icorrext.
Testing completed (on m-c, etc.): Tested on c-c, SeaMonkey 
Risk to taking this patch (and alternatives if risky): no risk.
String changes made by this patch: none.
Attachment #8735308 - Flags: approval-comm-release+
Attachment #8735308 - Flags: approval-comm-beta+
Attachment #8735308 - Flags: approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.