[TV] TV FTU do not run at first time setup

RESOLVED WONTFIX

Status

Firefox OS
Gaia::First Time Experience
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: twen, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5?)

Details

(Whiteboard: [ft:conndevices])

(Reporter)

Description

2 years ago
According to the latest spec: FTE Spec v2.5_20160323.pdf https://drive.google.com/open?id=0BwbmH5cX2W6OMEo0cUVXN251Mmc FTE is to run after first time tv setup. However, I have found that FTU exist as an app and not automatically run at first time setup. 

Actual:
- Run as an app 

Expected:
- FTU run at first time setup

I need help with clarification.

Comment 1

2 years ago
The cooperation model is that we make the app and partner put it into the 1st time tv setup. As a result, we only let TV FTU appear in the app deck under the engineering mode in our code base. The partner will integrate this TV FTU app into its own tv's 1st time setup code.

Comment 2

2 years ago
[Blocking Requested - why for this release]: The bug is raising because we have inconsistent spec and implementation in our internal TV build. If the FTU app is the final decision we propose to any partner to build their own FTU experience, we need to change our spec. Otherwise the spec's behaviour should be implemented in our internal build. QA won't know which one we should follow if we always have inconsistent spec and implementation.

Hi Josh, please help to clarify this issue, thanks.
blocking-b2g: --- → 2.5?
Flags: needinfo?(jocheng)

Updated

2 years ago
Flags: needinfo?(jocheng)
Whiteboard: [ft:conndevices]

Comment 3

2 years ago
Current FTU is implemented by partner. Before we introduce whole partner implementation, we will keep this as it is.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.