about:home page not displayed on the Windows Child Mode try build

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: alindeac, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Mozilla/5.0 (Windows NT 6.3; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160318150935

[Note]:
Reproducible only on the try build from:
https://archive.mozilla.org/pub/firefox/try-builds/dkeeler@mozilla.com-2c114e65c871c037f77babda41eebfff544a77f2/


[Affected versions]:
only on the try build mentioned above

[Affected platforms]:
Windows 8.1

[Steps to reproduce]:
1. Launch Firefox with a new profile
2. In 3 different tabs navigate to 3 different websites
3. Close Firefox - when the Confirmation Close dialog prompts you -> click on the Close tabs button
4. Open Firefox again



[Expected result]:
After step 5, the about:home page should open, giving you the possibility Restore the Previous session.

[Actual result]:
The about:home is not opened. This page is opened instead:
https://www.mozilla.org/en-US/firefox/new/?utm_source=firefox-com&utm_medium=referral

[Regression range]:
not a regression

[Additional notes]:
Not reproducible on: Firefox 45.0.1 RC, Firefox 46.0b5, Firefox Developer Edition 47.0a2, Nightly 48.0a1.
Following the steps to reproduce, I arrive at the about:home page. Can you check again that this is reproducible?
Flags: needinfo?(simona.marcu)
Created attachment 8736174 [details]
Screencast with the actual results

I'm attaching a screen-cast with the results I'm getting when following this scenario.
Flags: needinfo?(simona.marcu)
Created attachment 8736178 [details]
screenshot.png

Please see the attached screenshot with the page I'm seeing when I follow the scenario from the description on the latest Nightly ( Version 48.0a1, Build ID: 20160327030437). 

This is the about:home page I was expecting after step 4 (sorry for the step 5 I'm referring to in the Expected results from the Description, it's clearly a mistake :) ).
I also couldn't reproduce this using the latest try build (comment #4) that was provided by :keeler. I went through the following:

Build Used: https://hg.mozilla.org/try/rev/0178e1dc8e743c5856e36d92d5dab93abb2601ad
OS Used: Win 8.1 x64 VM

* going through case without using security.family_safety.mode within Child Mode
* going through the case while using security.family_safety.mode;2 within Child Mode
* going through case without using security.family_safety.mode within the Administrator account
* going through the case while using security.family_safety.mode;2 within the Administrator account

From the looks of the fx icon that I noticed in the video from comment #2, it seems like the issue occurred in either beta/release and not in the nightly try build.
(In reply to Simona B [:simonab] from comment #4)
> David, the issue is not reproducible on the more recent try build from:
> 
> https://archive.mozilla.org/pub/firefox/try-builds/dkeeler@mozilla.com-
> 0178e1dc8e743c5856e36d92d5dab93abb2601ad/

Ok - sounds like this isn't an issue anymore.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(In reply to Kamil Jozwiak [:kjozwiak] from comment #5)
> I also couldn't reproduce this using the latest try build (comment #4) that
> was provided by :keeler. I went through the following:
> 
> Build Used:
> https://hg.mozilla.org/try/rev/0178e1dc8e743c5856e36d92d5dab93abb2601ad
> OS Used: Win 8.1 x64 VM
> 
> * going through case without using security.family_safety.mode within Child
> Mode
> * going through the case while using security.family_safety.mode;2 within
> Child Mode
> * going through case without using security.family_safety.mode within the
> Administrator account
> * going through the case while using security.family_safety.mode;2 within
> the Administrator account
> 
> From the looks of the fx icon that I noticed in the video from comment #2,
> it seems like the issue occurred in either beta/release and not in the
> nightly try build.

Thanks for taking the time to look over. 
The screen cast was done from the try build mentioned in the Description (the desktop icon for the try build was not visible in the screen cast).
You need to log in before you can comment on or make changes to this bug.