Change perfherder's signatures endpoint to be more efficient

RESOLVED FIXED

Status

Tree Management
Perfherder
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: wlach, Assigned: wlach)

Tracking

Details

Attachments

(1 attachment)

1. Remove subtest_signatures from the return value (it's super slow to generate this property, because it requires a database query for every signature with subtests). Instead, add a parent_signature and has_subtests property to each return value (the latter will require an addition to the database schema).
2. Make it optionally possible to only fetch tests without a parent signature (many views only need these signatures, so it's wasteful to fetch everything).

Comment 1

2 years ago
Created attachment 8735558 [details] [review]
[treeherder] wlach:1260110 > mozilla:master
Blocks: 1257954

Comment 2

2 years ago
Commits pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/70e00bc6dace2da9382424db53d8efd273344448
Bug 1260110 - Add a "has subtests" property to performance series

This will be useful for some views where we don't know off the bat
whether a signature has subtests or not (e.g. the e10s dashboard,
the graphs view) and thus whether to show a "show subtests button"

https://github.com/mozilla/treeherder/commit/41da1094033b4d94938129cf908107e506f1711e
Bug 1260110 - Re-work the signature fetching API to be faster

* Remove subtest_signatures property (super slow)
* Add a parent_signature property to signatures with a parent signature
* Add option to only fetch signatures without a parental signature
* Update clients to use the new API, for increased speed/awesomeness
:jmaher was away so i just landed this change, after careful testing
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1234868
You need to log in before you can comment on or make changes to this bug.