Firefox freezes when opening files with the extension .osz

RESOLVED WORKSFORME

Status

Core Graveyard
File Handling
--
trivial
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: darius.tipple, Unassigned)

Tracking

45 Branch
mozilla45
x86_64
Windows 10

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
I am experiencing a problem when trying to open files with the extension *.osz using my Firefox Browser. The files are hosted online and I am trying to access them through clicking hyperlinks. 

Firefox will instantly freeze upon me interacting with the link (whether that is clicking it, opening in new tabs or windows, saving it, or pasting it into my address bar), and I am forced to close Firefox to use it again. To reproduce the freezing;
1. Go to this forum - http://osu.ppy.sh/forum/t/422304/start=0
2. Scroll down to the Song List, and click on any of the blue hyperlinks.

To fix the problem I have already tried the following to no avail:
- scanning my computer with antivirus and antimalware software, both returned no detections;
- refreshing Firefox using this guide - https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings, bug still present
- creating a new profile;
- restarting my computer several times.

I report this as a bug because this used to work absolutely fine up until yesterday, and I am unaware of making any significant changes to my computer then. What used to happen would be the link would direct me to the Unicode version of the file which I could then save to my computer using Ctrl-S.

Any help or pointers are much appreciated.

Comment 1

2 years ago
No issue for me to click on these links like http://puu.sh/n5ItF/28bd7a0cd7.osz

Does it work in safe mode?
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Flags: needinfo?(darius.tipple)

Comment 2

2 years ago
In addition, to which software are associated .osz files on your machine?
(Reporter)

Comment 3

2 years ago
Thanks for the reply. The links work correctly when I use Safe Mode.

.osz files are only attributed to the osu! game client.
Flags: needinfo?(darius.tipple)

Comment 4

2 years ago
On my machine, .osz are associated wrongly (I guess) to WinRAR (for an unknown reason that I ignore). Could you change the file association for this extension in Win 10, and test again.
(Reporter)

Comment 5

2 years ago
I changed the assosciation to 7-Zip Console, restarted and it worked fine.

Thanks so much!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Updated

2 years ago
Component: General → File Handling
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.