Closed Bug 1260127 Opened 4 years ago Closed 4 years ago

Today pane: changing the number of days in the "Upcoming" section can cause an error "soonHeader is null"

Categories

(Calendar :: General, defect)

Lightning 4.0.6
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bv1578, Assigned: bv1578)

Details

Attachments

(1 file)

Steps to reproduce:
- display events in Today pane and set a day different than today in the miniday or minimonth so that the sections "Tomorrow" and "Upcoming" disappear from the pane;
- in the Options menu, set a different preference for the number of days to display in the "Upcoming" section.

--> the error "TypeError: soonHeader is null" appears in the console, Today pane still works though.
Attached patch patch-v1Splinter Review
Attachment #8735450 - Flags: review?(makemyday)
Comment on attachment 8735450 [details] [diff] [review]
patch-v1

Review of attachment 8735450 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm, r+
Attachment #8735450 - Flags: review?(makemyday) → review+
Keywords: checkin-needed
Comment on attachment 8735450 [details] [diff] [review]
patch-v1

This should be safe for Aurora and Beta as well.
Attachment #8735450 - Flags: approval-calendar-beta?(philipp)
Attachment #8735450 - Flags: approval-calendar-aurora?(philipp)
http://hg.mozilla.org/comm-central/rev/2b8ddf24b85e
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 5.0
Attachment #8735450 - Flags: approval-calendar-beta?(philipp)
Attachment #8735450 - Flags: approval-calendar-beta+
Attachment #8735450 - Flags: approval-calendar-aurora?(philipp)
Attachment #8735450 - Flags: approval-calendar-aurora+
This tests are now failing permanently:
WARNING - TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js | xpcshell return code: 0 

WARNING - TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js | test_loadCalendar - [test_loadCalendar : 12] false == true 

Decathlon, please can you look at them if this comes from your patch?
Flags: needinfo?(bv1578)
That test failure is not related to this patch. That is bug 1244818.
Flags: needinfo?(bv1578)
Since we are near the end of the month it seems that Bug 1103187 is causing again bug 1244818 (see bug 1244818 comment 2).
There's a patch for bug 1103187 that has been applied for libical but not for ical.js. If you need it, I can provide a patch for bug 1103187 only for ical.js.
You mean there's a patch for ical.js but not for libical, right? The PR for ical.js from bug 1103187 has already been merged upstream and will therefor land on cc with the patches in bug 1115667 - so for ical.js there's no additional action required.
(In reply to MakeMyDay from comment #8)
> You mean there's a patch for ical.js but not for libical, right?

Yes, that bug is only on ical.js, I was thinking to another bug.

 The PR for
> ical.js from bug 1103187 has already been merged upstream and will therefor
> land on cc with the patches in bug 1115667 - so for ical.js there's no
> additional action required.

Yes, Bug 1115667 will fix bug 1103187 that will fix bug 1244818 :)

> so for ical.js there's no additional action required.

Yes, other than wait for bug 1115667.
Alternatively we could fix the file ical.js on comm-central (it's only five code lines) without wait for the big changes of bug 1115667. Then we have to remember those five lines before the big patch from that bug.
It would avoid the test failure every end of month.
The icaljs merge to cc has already r+, so it should just be a matter of days to get them landed by Fallen - so leave it as it is.
Target Milestone: 5.0 → 4.8
You need to log in before you can comment on or make changes to this bug.