Youtube Video In Fullscreen Buffer Incorrectly

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
P2
normal
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Brenda Make, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160315153207

Steps to reproduce:

(I don't use Flash.)

Go to Youtube.
Watch a video.
make it fullscreen.




Actual results:

Video has temporal errors, with random previous split-second segments.

This only seems to happen in fullscreen.

This only seems to happen with Firefox.Youtube.


Expected results:

Video should have played smoothly.

Updated

2 years ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
Can you please open about:support and post the contents of that here? That will give us some details about your system and help us diagnose the problem.
Flags: needinfo?(brendieellen)
Priority: -- → P2
(Reporter)

Comment 2

2 years ago
Hi, the bug only happens with hardware acceleration on.

Apparently, this is a known unfixed bug : (


Application Basics
------------------

Name: Firefox
Version: 45.0.2
Build ID: 20160407164938
Update Channel: release
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Multiprocess Windows: 0/1 (default: false)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: 1-Click YouTube Video Downloader
Version: 2.4.0.4
Enabled: true
ID: YoutubeDownloader@PeterOlayev.com

Name: Cookie Whitelist, With Buttons
Version: 3.3
Enabled: true
ID: cwwb@dietrich.cx

Name: Firefox Hello Beta
Version: 1.1.14
Enabled: true
ID: loop@mozilla.org

Name: Full Screen Image Viewer
Version: 5.1.1-signed
Enabled: true
ID: imageviewer@toptip.ca

Name: Grab and Drag
Version: 3.2.5.2.1-signed
Enabled: true
ID: {477c4c36-24eb-11da-94d4-00e08161165f}

Name: ImageBlock
Version: 3.1
Enabled: true
ID: imageblock@hemantvats.com

Name: ScrapBook
Version: 1.5.13.1-signed
Enabled: true
ID: {53A03D43-5363-4669-8190-99061B2DEBA5}

Name: Tab Preview
Version: 0.3.1-signed
Enabled: true
ID: {1de0de3c-0b5c-4f67-90c6-689623894991}

Name: Youtube Downloader - 4K Download
Version: 7.1.0
Enabled: true
ID: paulsaintuzb@gmail.com

Name: New Tab by Yahoo
Version: 1.3.2
Enabled: false
ID: jid1-G80Ec8LLEbK5fQ@jetpack

Graphics
--------

Adapter Description: Intel(R) HD Graphics 4600
Adapter Description (GPU #2): NVIDIA Quadro K2100M
Adapter Drivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
Adapter Drivers (GPU #2): nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
Adapter RAM: Unknown
Adapter RAM (GPU #2): 2048
Asynchronous Pan/Zoom: none
Device ID: 0x0416
Device ID (GPU #2): 0x11fc
Direct2D Enabled: true
DirectWrite Enabled: true (10.0.10586.0)
Driver Date: 2-2-2016
Driver Date (GPU #2): 10-27-2015
Driver Version: 20.19.15.4380
Driver Version (GPU #2): 10.18.13.5442
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 221e17aa
Subsys ID (GPU #2): 221e17aa
Supports Hardware H264 Decoding: Yes
Vendor ID: 0x8086
Vendor ID (GPU #2): 0x10de
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4600 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.enable: false
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.frecency_experiment: 3
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20160315153207
browser.startup.homepage_override.buildID: 20160407164938
browser.startup.homepage_override.mstone: 45.0.2
browser.tabs.remote.disabled-for-a11y: true
browser.tabs.warnOnClose: false
browser.urlbar.userMadeSearchSuggestionsChoice: true
dom.apps.reset-permissions: true
dom.mozApps.used: true
extensions.lastAppVersion: 45.0.2
font.internaluseonly.changed: false
font.size.variable.x-western: 18
general.autoScroll: false
gfx.crash-guard.d3d11layers.appVersion: 45.0.2
gfx.crash-guard.d3d11layers.deviceID: 0x0416
gfx.crash-guard.d3d11layers.driverVersion: 20.19.15.4380
gfx.crash-guard.d3d11layers.feature-d2d: true
gfx.crash-guard.d3d11layers.feature-d3d11: true
gfx.crash-guard.glcontext.appVersion: 45.0.2
gfx.crash-guard.glcontext.deviceID: 0x0416
gfx.crash-guard.glcontext.driverVersion: 20.19.15.4380
gfx.crash-guard.glcontext.gfx.driver-init.direct3d11-angle: true
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle: true
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-d3d11: false
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-warp: false
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-try-d3d11: true
gfx.crash-guard.status.d3d11layers: 2
gfx.crash-guard.status.d3d9video: 2
gfx.crash-guard.status.glcontext: 2
gfx.direct3d.last_used_feature_level_idx: 0
gfx.driver-init.appVersion: 42.0
gfx.driver-init.deviceID: 0x0416
gfx.driver-init.driverVersion: 20.19.15.4300
gfx.driver-init.feature-d2d: true
gfx.driver-init.feature-d3d11: true
gfx.driver-init.status: 2
media.gmp-eme-adobe.abi: x86-msvc-x64
media.gmp-eme-adobe.lastUpdate: 1453918617
media.gmp-eme-adobe.version: 15
media.gmp-gmpopenh264.abi: x86-msvc-x64
media.gmp-gmpopenh264.lastUpdate: 1454014362
media.gmp-gmpopenh264.version: 1.5.3
media.gmp-manager.buildID: 20160407164938
media.gmp-manager.lastCheck: 1461257968
media.hardware-video-decoding.failed: false
media.youtube-ua.override.to: 43
network.cookie.cookieBehavior: 1
network.cookie.lifetimePolicy: 2
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1460836830
places.history.enabled: false
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.npdeployjava: 0
plugin.state.npnv3dv: 0
plugin.state.npnv3dvstreaming: 0
print.printer_NovaJet_Pro_36.print_bgcolor: false
print.printer_NovaJet_Pro_36.print_bgimages: false
print.printer_NovaJet_Pro_36.print_duplex: -437918235
print.printer_NovaJet_Pro_36.print_edge_bottom: 0
print.printer_NovaJet_Pro_36.print_edge_left: 0
print.printer_NovaJet_Pro_36.print_edge_right: 0
print.printer_NovaJet_Pro_36.print_edge_top: 0
print.printer_NovaJet_Pro_36.print_evenpages: true
print.printer_NovaJet_Pro_36.print_footercenter:
print.printer_NovaJet_Pro_36.print_footerleft: &PT
print.printer_NovaJet_Pro_36.print_footerright: &D
print.printer_NovaJet_Pro_36.print_headercenter:
print.printer_NovaJet_Pro_36.print_headerleft: &T
print.printer_NovaJet_Pro_36.print_headerright: &U
print.printer_NovaJet_Pro_36.print_in_color: true
print.printer_NovaJet_Pro_36.print_margin_bottom: 0.5
print.printer_NovaJet_Pro_36.print_margin_left: 0.5
print.printer_NovaJet_Pro_36.print_margin_right: 0.5
print.printer_NovaJet_Pro_36.print_margin_top: 0.5
print.printer_NovaJet_Pro_36.print_oddpages: true
print.printer_NovaJet_Pro_36.print_orientation: 1
print.printer_NovaJet_Pro_36.print_page_delay: 50
print.printer_NovaJet_Pro_36.print_paper_data: 260
print.printer_NovaJet_Pro_36.print_paper_height: 11.00
print.printer_NovaJet_Pro_36.print_paper_name:
print.printer_NovaJet_Pro_36.print_paper_size_type: 0
print.printer_NovaJet_Pro_36.print_paper_size_unit: 0
print.printer_NovaJet_Pro_36.print_paper_width: 8.50
print.printer_NovaJet_Pro_36.print_resolution: -437918235
print.printer_NovaJet_Pro_36.print_reversed: false
print.printer_NovaJet_Pro_36.print_scaling: 1.00
print.printer_NovaJet_Pro_36.print_shrink_to_fit: true
print.printer_NovaJet_Pro_36.print_to_file: false
print.printer_NovaJet_Pro_36.print_unwriteable_margin_bottom: 0
print.printer_NovaJet_Pro_36.print_unwriteable_margin_left: 0
print.printer_NovaJet_Pro_36.print_unwriteable_margin_right: 0
print.printer_NovaJet_Pro_36.print_unwriteable_margin_top: 0
privacy.clearOnShutdown.offlineApps: true
privacy.sanitize.migrateClearSavedPwdsOnExit: true
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.sanitizeInProgress: ["cache","cookies","offlineApps","history","formdata","downloads","sessions"]
privacy.sanitize.sanitizeOnShutdown: true
privacy.trackingprotection.pbmode.enabled: false
services.sync.declinedEngines:
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1460733402
ui.osk.debug.keyboardDisplayReason: IKPOS: Touch screen not found.

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.12
Version in use: 4.12

NSS
Expected minimum version: 3.21.1 Basic ECC
Version in use: 3.21.1 Basic ECC

NSSSMIME
Expected minimum version: 3.21.1 Basic ECC
Version in use: 3.21.1 Basic ECC

NSSSSL
Expected minimum version: 3.21.1 Basic ECC
Version in use: 3.21.1 Basic ECC

NSSUTIL
Expected minimum version: 3.21.1
Version in use: 3.21.1

Experimental Features
---------------------
Flags: needinfo?(brendieellen)
(Reporter)

Comment 3

2 years ago
This is an awful bug.

If I turn off hardware acceleration, the CPU has to work really hard and the video stutters from slowness.
If I turn it on, the video looks like it jitters from constantly resizing, or playing previous intermediate frames.
Please look into it.

I would be curious about the GPU's video acceleration, BUT it only happens in full screen.
(Reporter)

Comment 4

2 years ago
It looks similar to this: https://www.youtube.com/watch?v=2ejiiSTHwV8
I only have this problem in Firefox, and only with HW on.
(Reporter)

Comment 5

2 years ago
It seems to be Intel's fault. I downloaded new beta graphic drivers, and it seems to be working! Yay!

Intel f'ed up.

In reading the readme, there was an issue with the VP8 decompression, so I only saw it in Firefox, so I assumed is was Firefox's fault. Most everything else used mpeg-style decompression, so it was unaffected. I don't use optimus for browsing, so it couldn't ever have been that.
ReleaseNotes_GFX_15 40 4404.pdf

Sorry about this one folks, but it was unusable.
Brenda

Gees, I hat the status choices; there's non for a bug that's not Firefox fault.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.