Enable URL hover previews for responsive content

RESOLVED DUPLICATE of bug 1064715

Status

RESOLVED DUPLICATE of bug 1064715
3 years ago
8 months ago

People

(Reporter: jdm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Currently only <img src="..."> is recognized. Responsive images allow <img srcset="..."> as well as <source srcset="...">, both of which could contain multiple URLs.

isImagePreviewTarget and isPreviewable in markup.js look like a reasonable place to start updating this logic. After that it's probably necessary to chase the getImageData implementation that's called from _getPreview.
This has already been filed under bug 1064715.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1064715

Updated

8 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.