Closed Bug 1260269 Opened 6 years ago Closed 5 years ago

xpi files get built with extraneous zero size xpi inside it

Categories

(Firefox Build System :: General, defect)

All
Linux
defect
Not set
normal

Tracking

(firefox47 unaffected, firefox48 wontfix, firefox49 fix-optional, firefox50 fix-optional)

RESOLVED DUPLICATE of bug 1240676
Tracking Status
firefox47 --- unaffected
firefox48 --- wontfix
firefox49 --- fix-optional
firefox50 --- fix-optional

People

(Reporter: iannbugzilla, Unassigned)

Details

(Keywords: regression)

Path to obj-src is /mozdev/central/m-c/obj-src

Steps to reproduce:
1/ Pull latest m-c
2/ Build using make -f client.mk
3/ Examine content of an xpi file under obj-src/dist/xpi-stage

Expected result (for specialpowers):
1/ just chrome directory and contents along with bootstrap.js, chrome.manifest and install.rdf

Actual result
1/ Extra file (specialpowers@mozilla.org.xpi) in directory structure /mozdev/central/m-c/obj-src/dist/xpi-stage
Greg, are you still the module owner? Can you help find someone to look at this bug since it's a fairly recent regression? Thanks!
Flags: needinfo?(gps)
Smells like fallout from some refactoring glandium did a while back.
Flags: needinfo?(gps) → needinfo?(mh+mozilla)
The code doing these xpi is broken in so many ways, I'm going to call this a dupe of bug 1240676. And because I'm sick of bug 1256004, I think I'm going to tackle it.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(mh+mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1240676
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.