Cannot select breakpoint detail scrolled below if there are many details and vertical scrollbar

RESOLVED DUPLICATE of bug 1204142

Status

P2
normal
RESOLVED DUPLICATE of bug 1204142
3 years ago
5 months ago

People

(Reporter: magicp.jp, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(firefox45 affected, firefox46 affected, firefox47 affected, firefox48 affected, firefox-esr45 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8735628 [details]
cannot select breakpoint detail.mp4

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160328030215

Steps to reproduce:

1. Start any versions Firefox
2. Go to any sites (e.g. about:home)
3. Open DevTools > Debugger
4. Select dbg-source-item (e.g. contentSearchUI.js)
5. Add many breakpoints until vertical scrollbar appears
6. Select breakpoint details in order


Actual results:

Cannot select a breakpoint detail scrolled below.


Expected results:

Select breakpoint details correctly.
(Reporter)

Updated

3 years ago
Has STR: --- → yes
status-firefox45: --- → affected
status-firefox46: --- → affected
status-firefox47: --- → affected
status-firefox48: --- → affected
status-firefox-esr45: --- → affected
Component: Untriaged → Developer Tools: Debugger
OS: Unspecified → All
Hardware: Unspecified → All
This looks like a UI papercut to me. James, perhaps something to be aware of?
Priority: -- → P2

Comment 2

3 years ago
Workaround: to perform mousedown, then scroll the breakpoint into view, then perform mouseup.

There're 5+ similar issues in devtools, they're accessible via "See also" links in bug 1204142 & Co
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1204142

Updated

5 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.