Closed Bug 1260329 Opened 4 years ago Closed 4 years ago

Properly escape the frameTable when running |dmd.py --clamp-contents|

Categories

(Core :: DMD, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla48
Tracking Status
firefox48 --- fixed

People

(Reporter: njn, Assigned: njn)

References

Details

Attachments

(1 file)

I was getting test failures on my Windows machine because |dmd.py
--clamp-contents| was not properly escaping backslashes in file paths when it
rewrote the JSON file.

I don't know why this wasn't causing problems on automation.
Comment on attachment 8735674 [details] [diff] [review]
Properly escape the frameTable when running |dmd.py --clamp-contents|

Review of attachment 8735674 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks. I think I've seen something like this before.
Attachment #8735674 - Flags: review?(continuation) → review+
Bug 1091262 is what I was thinking of, but I'm not sure if it is the same thing or not.
(In reply to Andrew McCreight [:mccr8] from comment #3)
> Bug 1091262 is what I was thinking of, but I'm not sure if it is the same
> thing or not.

If you were running with --clamp-contents (and I figure it's a good chance you were) then it would be the same problem. Let's be optimistic and call it a dup.
Duplicate of this bug: 1091262
https://hg.mozilla.org/integration/mozilla-inbound/rev/35053f4c889b0c2bec7812a6614d2b3eba2f349a
Bug 1260329 - Properly escape the frameTable when running |dmd.py --clamp-contents|. r=mccr8.
https://hg.mozilla.org/mozilla-central/rev/35053f4c889b
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
You need to log in before you can comment on or make changes to this bug.