Closed Bug 1260408 Opened 6 years ago Closed 6 years ago

Convert doorhanger notifications from Mozmill tests to Firefox Puppeteer

Categories

(Testing :: Firefox UI Tests, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1144873

People

(Reporter: whimboo, Unassigned)

Details

We need the doorhanger notification support in our Firefox UI Tests and therefore we should convert the existing code from Mozmill tests to Firefox Puppeteer as a ui class tight to the toolbar.

Doorhanger notifications you get e.g. when installing add-ons from AMO like:
https://addons.mozilla.org/en-US/firefox/addon/nightly-tester-tools/

Just click the install button and you will be presented with a doorhanger to accept the installation.

Mozmill tests related code should be all in toolbars.js and discoverable by searching for `notification`:

https://github.com/mozilla/qa-mozmill-tests/blob/master/firefox/lib/toolbars.js#L883
This work has actually been done on bug 1144873.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1144873
You need to log in before you can comment on or make changes to this bug.