Rendering errors using Webwasher as Proxy

RESOLVED WORKSFORME

Status

()

Core
Networking
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Volker Sauer, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Hi,

I'm using webwasher Version 3.0 (a programm similar to junkbuster,
www.webwasher.com) together with squid-2.3STABLE4 to filter HTTP-Connections for
unwanted content like ads and JS-Popup-Windows. Both programms (squid and
webwasher) run on my proxy server on the internal interface. The external
interface is connected to the internet. In our Network, there is a cisco
transparent-proxy-server, too. 
Webwasher answers requests on port 9090 and squid can be accessed on port 8080.
Webwasher itself internally fetches the data from squid using it's port 8080,
because it doesn't implement a cache engine, just a filter.
With the following browser/system-combinations everything works well since years.
konquerer2.2.2/linux
netscape4.78/linux
opera5&6/linux
InternetExplorer4,5,6/Windows
Netscape/Windows

With Mozilla on Linux I have the following problem since first trying mozilla
version 0.9.1:
Mozilla used with squid as http-proxy works fine.
Mozilla used with webwasher as http-proxy brings up the following errors:

On almost all my favorite sites (e.g. www.heise.de, www.spiegel.de,
www.partyamt.de) mozilla brings up the following text in one or sometimes more
frames instead of the correct content:

0 HTTP/1.1 200 OK Content-Type: text/html Date: Sun, 17 Feb 2002 18:52:59 GMT
Last-Modified: Sun, 17 Feb 2002 18:52:59 GMT Proxy-Connection: keep-alive
Server: Apache/1.3.12 (Unix) mod_oas/4.65 Transfer-Encoding: chunked Via: 1.1
www.spiegel.de X-Cache: MISS from prx017.spiegel.ision.net X-Cache: MISS from
z217.alex.wh.tu-darmstadt.de 44C  132
<http://spiegel.ivwbox.de/cgi-bin/ivw/CP/spiegel;/auto/werkstatt/c-139/r-265/k-1282/a-182130/be-PB64-YXV0bw_3_3?r=http%3A//www.spiegel.de/>
2E9
<http://www.spiegel.de/cgi-bin/vdz/CP/spiegel/auto/werkstatt/c-139/r-265/k-1282/a-182130/be-PB64-YXV0bw_3_3>



http://www.spiegel.de/ ist the site visited.
z217.alex.wh.tu-darmstadt.de is the machine running webwasher & squid.

One or more reloads then display the correct site.

As I already mentioned, I know the problem since at least version 0.9.1 and it's
still in 0.9.8 and should be fixed for the relaease 1.0 because webwasher is a
popular filter in germany (it work's a lot better than e.g. junkbuster)

Comment 1

17 years ago
WFM Mozilla/5.0 (Windows; U; Win98; de-AT; rv:0.9.8) Gecko/20020204
with WebWasher 3.2 beta3 and automatic browser-configuration
Reporter:
It seems that webwasher has problems with Http1.1.
Please change Http/1.1 to Http/1.0 in 
edit\preferences\Debug\Networking

it's probaply working with other browsers:
konquerer2.2.2/linux              use Http1.0 /AFAIK)
netscape4.78/linux                use always Http1.0
opera5&6/linux                    ? (I dunno)
InternetExplorer4,5,6/Windows     use Http/1.0 with Proxys
Netscape/Windows                  use always Http1.0

It's possible that this is a bug in webwasher 3.0
Assignee: asa → new-network-bugs
Component: Browser-General → Networking
QA Contact: doronr → benc
(Reporter)

Comment 3

17 years ago
Setting HTTP 1.0 in Debug->Network seems to work with webwasher
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

17 years ago
Well, setting HTTP 1.0 worked for quite a while now.
But now I'm getting errors on some sites (e.g. www.puretec.de and www.ltur.de.
Other sites seem to be still ok).
These sites contain quite a lot of small pictures.
Using HTTP 1.0 with WW 3.0 oftens causes mozilla (0.9.9) not to load these. Even
on reload, it just displays the "Picture not found"-logo.
Other sites work fine.
Setting HTTP 1.1 in mozilla corrects *this* problem, but causes the other one
already described below tocome up again, which i set to "resolved worksforme".
Using mozilla without webwasher (only with squid) everything works fine with
HTTP 1.0 and HTTP 1.1.

I suppose that these sites use HTTP 1.1 features, which WW can't handle! Do you
agree with that?
I sent a mail to webwasher.com, too.
I hope they'll implement HTTP 1.1 to theri product. Right now, only the
expensive Enterprise Edition auf WW implements it.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 5

16 years ago
Changed the order of the proxies WW and Squid:

- now browser connects squid
- squid connects webwasher
- webasher connects http-server

Now Mozilla has to talk too squid, which I think is a much more reliable
combination.
Now everything works fine again even with HTTP 1.1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 6

16 years ago
*** Bug 138542 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.