Window stays open when all tabs are closed onbeforeunload

VERIFIED DUPLICATE of bug 1238032

Status

()

VERIFIED DUPLICATE of bug 1238032
2 years ago
2 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox48 fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
>>>   My Info:   Win7_64, Nightly 48, 32bit, ID 20160326030430
STR:
0. Open new window with only one tab
1. Open the following "data:" url in that tab
>   data:text/html,<html onclick="W=window.open()"><body onbeforeunload="W.close()">
2. Click on the white area on the page
3. Close the tab from Step 1

AR:  The window didn't close and it lags a lot if you try to open/close Gear menu on New Tab page
ER:  The window should close.

This is regression from bug 305085. Regression range:
> https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=63006936ab99&tochange=c1f6345f2803
Comment hidden (spam)
(Reporter)

Updated

2 years ago
Summary: Windows stays open when all tabs are closed onbeforeunload → Window stays open when all tabs are closed onbeforeunload
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1238032
status-firefox48: affected → fixed
(Reporter)

Updated

2 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.