Closed Bug 1260605 Opened 4 years ago Closed 4 years ago

Wrong results displayed in some old-configure tests

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox48 fixed)

RESOLVED FIXED
mozilla48
Tracking Status
firefox48 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file)

For example:
checking for gethostbyname... no
checking for connect... no
checking for remove... no
checking for shmat... no

while the reality is that they all are yes (and that's confirmed by config.cache).

This comes from a hack in bug 967556 that was supposed to help prevent clobbers.

In practice the hack never really worked as intended.
Summary: Wrong values displayed in some old-configure tests → Wrong results displayed in some old-configure tests
The hack was supposed to avoid clobbers when landing bug 967556, which
might have worked somehow back then, but doesn't do anything useful
anymore. In fact, it now breaks the display of some results in
old-configure.

Review commit: https://reviewboard.mozilla.org/r/43103/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/43103/
Attachment #8736108 - Flags: review?(gps)
https://hg.mozilla.org/mozilla-central/rev/01b372afc3fc
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
Attachment #8736108 - Flags: review?(gps)
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.