Some downloads failed in firefox, like download slack from https://slack.com/downloads

RESOLVED WORKSFORME

Status

()

Core
Networking: HTTP
P1
critical
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: kh_harut, Assigned: bagder)

Tracking

45 Branch
x86_64
Windows
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-active])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160304114926

Steps to reproduce:

I tried to download slack from it's official page but download failed, but then I found remnants of 4 download attempts in my Download folder. It is strange. I struck the same issue in both Windows and Ubuntu systems.


Actual results:

Some download failed. I think the problem is that I am using 2 internet connection wifi and lan. Some packages goes through lan some through wifi and download manager can not decide what to use.


Expected results:

If download is impossible why then 4 or more download attempts is done.
(Reporter)

Updated

2 years ago
Severity: normal → critical
OS: Unspecified → Windows
Priority: -- → P1
Hardware: Unspecified → x86_64

Updated

2 years ago
Component: Untriaged → Networking: File
Product: Firefox → Core
Daniel, could this be something falling under your discretion?  Feel free to bounce back or to Jason.
Component: Networking: File → Networking: HTTP
Flags: needinfo?(daniel)
Whiteboard: [necko-active]
(Assignee)

Comment 2

2 years ago
(In reply to kh_harut from comment #0)

> Some download failed. I think the problem is that I am using 2 internet
> connection wifi and lan. Some packages goes through lan some through wifi
> and download manager can not decide what to use.

Both are used? How exactly is that working, can you elaborate on this setup?

Are you only seeing problems for this particular download or can you repeat it elsewhere as well? How much data does it manage to download (and how long time does that download take)?
Assignee: nobody → daniel
Flags: needinfo?(daniel)
(Reporter)

Comment 3

2 years ago
I use both connections. I have never got any problem like that. My laptop has two different IP-s.

I struck the same problem with different downloads and even on different computer. So I think it is not because of the multiple connections. Very similar to this I struck today when trying to open a pdf file in firefox. Again that file was not opened. Then an attempt of download initiated and at the end I got 4 failed downlands. And that was on different computer.
(Assignee)

Comment 4

2 years ago
(In reply to kh_harut from comment #3)
> I use both connections. I have never got any problem like that. My laptop
> has two different IP-s.

Still, a plain old normal TCP/IP stack has one single default route that you'll go through to reach a single destination and that means it'll only use one interface at a time. Many interfaces and IPs are normal but not that several are used in parallel to the same remote IP. Doing a single TCP transfer over multiple interfaces requires MPTCP or similar tricks, which is what made me ask. I want as much data as possible to see if I can reproduce this!

> I struck the same problem with different downloads and even on different
> computer.

HTTP and/or HTTPS? IPv4 and/or IPv6 ? Have you used the same Firefox versions (45) on both Windows and Ubuntu when experiencing these problems? Have you tried any more recent version (beta or nightly) just to see if they behave the same?

You're not using a proxy, right?

Would you be capable of generating HTTP logs or even wireshark captures of the network traffic around the time when you get these problems?

Do you experience that you can reproduce the problem easily when going back to one of the problematic sites, like the one mentioned in this bug's title?
(Reporter)

Comment 5

2 years ago
Yes I have the same 45.0.1 (esr) version on my workplace computer and 45.0.1 (without esr) in Ubuntu. And even just now I struck the same problem with download. It doesn't depends on webpage all downloads are failed even with Skype http://www.skype.com/ru/download-skype/skype-for-windows/downloading/. By the way Firefox stopped to open any pdf files either, (for example this http://arxiv.org/pdf/1603.09339). I have found that restarting Firefox fixes the problems, but it is annoying.
(Reporter)

Comment 6

2 years ago
I noticed that both links are http. Is it make any difference?
(Reporter)

Comment 7

2 years ago
I struck the same problem with even https pages,too. On both windows and linux. The problem is with firefox version 45.0.1. Please check pdf plugin. It starts when I try to open any pdf file in firefox. After it every download fails. After restart of firefox problem disappears. But after such a crush it impossible to reopen any page from previous session. The last thing is really annoying. Thank you in advance.
(Assignee)

Comment 8

2 years ago
Are you saying that you only see this problem once you've experienced that problem in the pdf plugin? So if you never view a PDF, you don't get to see the issue? Or is it just a way to make it trigger more easily? (I'm not saying I understand why this would be the case, just trying to understand if we're narrowing down the case here or not.)
Component: Networking: HTTP → XUL
(Assignee)

Comment 9

2 years ago
Grrr, accidentally changed component!
Component: XUL → Networking: HTTP
(Reporter)

Comment 10

2 years ago
I suspect that the problem is in pdf plugin. Another interesting behavior. In most cases, I noticed that when Firefox writes that download failed it actually downloads file and downloaded file is not corrupted. So main question is: why Firefox writes that download failed in case when download completed successfully?
(Assignee)

Comment 11

2 years ago
> when Firefox writes that download failed it actually downloads file and downloaded file is not corrupted.

That does indeed sound strange.

Are you still talking about this happening (primarily) for PDF files? If so, can you point out a specific URL/pdf file that gives you this problem?
(Reporter)

Comment 12

2 years ago
I think that with new version of Firefox 45.0.2 the problem somehow is fixed.
(Reporter)

Comment 13

2 years ago
Thank you very much.
thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.