Closed Bug 1260700 Opened 4 years ago Closed 4 years ago

Add accesskey to menuitems Ignore Subthread and Watch Thread in message context menu

Categories

(Thunderbird :: Mail Window Front End, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 48.0

People

(Reporter: nONoNonO, Assigned: nONoNonO)

Details

Attachments

(1 file, 2 obsolete files)

When you right click a message, all menuitems except Ignore Subthread and Watch Thread show an accesskey. Please add those to make keyboard navigation easier.
Attached patch NewAccesskeys.patch (obsolete) — Splinter Review
Assignee: nobody → o.e.ekker
Attachment #8736302 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8736302 [details] [diff] [review]
NewAccesskeys.patch

Review of attachment 8736302 [details] [diff] [review]:
-----------------------------------------------------------------

Stealing the review here.
W won't work since we have: Open Message in new _W_indow.
Attachment #8736302 - Flags: review?(mkmelin+mozilla)
Unfortunately Watch Thread doesn't have a key that isn't used already. Using the W doesn't really change anything for English (it is used now implicitly), but might help for other locales (I know it would help for Dutch).

In fact, in all menuitems all letters are already used, except for the y, but that one is discouraged to use because the tail might interfere with the underscore. If you want to use the y anyway, I can change the accesskey of either _R_ eply to Sender Only or Reply to _A_ ll, leaving either the r or a for Watch Thread.
Sorry for the late reply, doing the review didn't put me onto the CC.
(In reply to Onno Ekker [:nONoNonO UTC+1] from comment #3)
> Using the W doesn't really change anything for English
> (it is used now implicitly).
Sorry, I don't understand, typing W opens the message in a new window for me. What do you mean by "used implicitly"?

> In fact, in all menuitems all letters are already used, except for the y,
> but that one is discouraged to use because the tail might interfere with the
> underscore. If you want to use the y anyway, I can change the accesskey of
> either _R_ eply to Sender Only or Reply to _A_ ll, leaving either the r or a
> for Watch Thread.
I don't have an opinion, sorry. Let's ask Magnus.
Flags: needinfo?(mkmelin+mozilla)
IIRC the lack of available letters was the cause the accesskeys weren't added.

I suppose you could add empty accesskeys for en-US so localizers can add them if needed, but I'd be inclined not to give R and A to them, given both commands do have hotkeys so threadpane + accesskey would appear pretty much unused by anyone.
Flags: needinfo?(mkmelin+mozilla)
(In reply to Jorg K (GMT+2) from comment #4)
> Sorry for the late reply, doing the review didn't put me onto the CC.
> (In reply to Onno Ekker [:nONoNonO UTC+1] from comment #3)
> > Using the W doesn't really change anything for English
> > (it is used now implicitly).
> Sorry, I don't understand, typing W opens the message in a new window for
> me. What do you mean by "used implicitly"?
I happened to have an add-on installed which also used the W, which caused the W not to immediately select Open message in new window, but to toggle between the three menuitems. By default W indeed selects the first  option.

(In reply to Magnus Melin from comment #5)
> IIRC the lack of available letters was the cause the accesskeys weren't
> added.
> 
> I suppose you could add empty accesskeys for en-US so localizers can add
> them if needed, but I'd be inclined not to give R and A to them, given both
> commands do have hotkeys so threadpane + accesskey would appear pretty much
> unused by anyone.
If it is possible to add it with an empty accesskey, I think it may help in other locales…
Attached patch NewAccesskeys_v2.patch (obsolete) — Splinter Review
Changed accesskey for Watch Thread to empty accesskey and verified that it works
Attachment #8736302 - Attachment is obsolete: true
Attachment #8737630 - Flags: review?(mozilla)
You might consider adding this:
<!--LOCALIZATION NOTE (contextWatchThreadMenu.accesskey):
   In the en-US locale we ran out of access keys, so there is an empty access key for
   Watch Thread. Localisers can pick a suitable key -->
With added comment
Attachment #8737630 - Attachment is obsolete: true
Attachment #8737630 - Flags: review?(mozilla)
Attachment #8737634 - Flags: review?(mozilla)
Comment on attachment 8737634 [details] [diff] [review]
NewAccesskeys_v3.patch

Review of attachment 8737634 [details] [diff] [review]:
-----------------------------------------------------------------

OK, US English rules here and it's Localizers with a zee ;-)
Attachment #8737634 - Flags: review?(mozilla) → review+
Yup, I figured when it says LOCALIZATION NOTE it should also say localizer with a zee
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/4ac9a0e7615af3a41526b79390fd3e67e2dd9364
Bug 1260700 -  Add accesskey to menuitems Ignore Subthread and Watch Thread in message context menu. r=jorgk
Status: NEW → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 48.0
You need to log in before you can comment on or make changes to this bug.