Session isnt correctly saved and/or incorreclty restored when manually entering url in tab starting in version 43

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
--
critical
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: EliUmniCk, Unassigned)

Tracking

({dataloss})

43 Branch
x86_64
Windows 7
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

New installation of FF 43.0.4 or above, with new profile.

Options to change from default setup :
	- "general", set "display previous tab"
	- "private life", set "use custom configuration for history". Uncheck "accept cookies"
	- close the option tab

Open a new tab, type in an url (for example http://forum.kerbalspaceprogram.com/index.php?/topic/135201-rssro-issue/)

When the tab has finished loading, close FF.

Reopen FF.

Additional info :

I used the url given in that example to discover the bug, but the url itself doesnt matter.

This behaviour happend since v43 (tested versions v43.0.4, v44.0.2, v45.0.1). I triyed v42.0, and it gives the expected result.

I m using windows seven x64 SP1 on real hardware. I was also able to reproduce the bug in a VM running windows seven x64 SP1.


Actual results:

A blank tab is displayed


Expected results:

tab with url http://forum.kerbalspaceprogram.com/index.php?/topic/135201-rssro-issue/ is reloaded
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64

Updated

2 years ago
Component: Untriaged → Session Restore
(Reporter)

Comment 1

2 years ago
I also find other cases where session restore behavior didnt work as expected. But unfortunatly, i couldn't make good test case to reproduce them.

I'm now back on v42.0 since 2 days, and it seems i dont have any more trouble with session restore.

I guess changes where introduced in v43.X.
EliUmniCk, do this still reproduce if you use the most current version?
Severity: normal → critical
Flags: needinfo?(bruno.g.dufay)
Keywords: dataloss
Summary: Session isnt correctly saved and/or incorreclty restored when manually entering url in tab → Session isnt correctly saved and/or incorreclty restored when manually entering url in tab starting in version 43
(Reporter)

Comment 3

a year ago
Sorry for not answering before. I took some times to make sure i did not find any case where session is not correctly saved.

So, no, i can't reproduce this bug using the version 50.0.2.

Comment 4

a year ago
WFM with comment 0 STR and an clean profile in Fx43.0.4 on Win10.
(Reporter)

Comment 5

a year ago
Sorry YF, but i dont understand what you ask.

If you ask me to try to reproduce the bug using FF 43.0.4 on Win10, well i dont have win10.
Flags: needinfo?(bruno.g.dufay) → needinfo?

Comment 6

a year ago
Just a report, as I can't reproduce it with your STR.

Based on your results, I marked the bug as WFM, reopen if it reoccurs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.