If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

% sign at the end of arabic text is located at the beginning of the text

VERIFIED INVALID

Status

()

Core
Layout: Text
VERIFIED INVALID
2 years ago
2 years ago

People

(Reporter: Dr. Sherif Omran, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8736410 [details]
Screen Shot 2016-03-30 at 8.17.07 PM.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160315153207

Steps to reproduce:

open a new paper website for example this site
http://ara.reuters.com/article/businessNews/idARAKCN0WW1WP, 
look at the title 
% sign should be at the end of the text (far left) it appears at the far right (beginning of the text)



Actual results:

% sign in the title should be at the end of the text (far left) it appears at the far right (beginning of the text)


Expected results:

it should be located at the end of the (right to left) text at the far left after the letter 6

Updated

2 years ago
Component: Untriaged → Layout: Text
Product: Firefox → Core
This is not a Firefox bug (and note that the same "problem" shows up in other browsers such as Chrome and Safari). The issue is that the page does not specify the dir=rtl attribute on the HTML content that should be displayed with right-to-left directionality.

So although the Arabic text runs right-to-left, the overall line direction is left-to-right, and in a left-to-right line, a final % sign appears at the far right.

If the page is corrected to specify dir=rtl on the appropriate elements (e.g. on the <div> with id=mainContent, if it's not wanted on the top-level <html> element), then the overall line/paragraph direction will be right-to-left and the trailing % sign will appear at the left, as expected.

This should be reported to the website concerned; it's their problem, not a browser bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

2 years ago
Please add a small code in order not to depend on the page style, check if the language is RTL and there is a % sign at the start/end of the line, it has to appear at the end of the line, the % sign must be after some number. the % sign can not start at the beginning, it causes huge understanding problems
(Reporter)

Comment 3

2 years ago
(In reply to Jonathan Kew (:jfkthame) [PTO this week] from comment #1)
> This is not a Firefox bug (and note that the same "problem" shows up in
> other browsers such as Chrome and Safari). The issue is that the page does
> not specify the dir=rtl attribute on the HTML content that should be
> displayed with right-to-left directionality.
> 
> So although the Arabic text runs right-to-left, the overall line direction
> is left-to-right, and in a left-to-right line, a final % sign appears at the
> far right.
> 
> If the page is corrected to specify dir=rtl on the appropriate elements
> (e.g. on the <div> with id=mainContent, if it's not wanted on the top-level
> <html> element), then the overall line/paragraph direction will be
> right-to-left and the trailing % sign will appear at the left, as expected.
> 
> This should be reported to the website concerned; it's their problem, not a
> browser bug.

Internet explorer and Chrom are not the standard to compare with, we create the standard.
(Reporter)

Comment 4

2 years ago
Please note the overall text direction in Arabic is RTL (not LTR as Jonathan said). If an english text appears with an arabic text, only the english text has to have the LTR direction and then the sentence should continue RTL.
You can work around this by using the "Switch Page Direction" command in the View menu. (If there is no such command in the menu, go to about:config and set "bidi.browser.ui" to "true")
(In reply to Dr. Sherif Omran from comment #4)
> Please note the overall text direction in Arabic is RTL (not LTR as Jonathan
> said).

Jonathan didn't mean that the Arabic *script* is LTR, but that the web page didn't specify RTL direction for its content, so by default it gets rendered LTR. This is correct by the HTML standard and it would be wrong to roll our own "standard" for mixed-language and mixed-direction texts.

> If an english text appears with an arabic text, only the english text
> has to have the LTR direction and then the sentence should continue RTL.

We can't necessarily tell from the content whether what we have is Arabic text in an English paragraph with an overall LTR direction, or English text in an Arabic paragraph with an overall RTL direction. This is why HTML has the dir attribute so that authors can specify the direction they want.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.