If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Treeherder reports green push even if artifacts are not found

RESOLVED DUPLICATE of bug 1157425

Status

Taskcluster
General
RESOLVED DUPLICATE of bug 1157425
2 years ago
a year ago

People

(Reporter: mcomella, Assigned: garndt)

Tracking

Details

(Reporter)

Description

2 years ago
Which is unintuitive.

I misconfigured my new job to run the 64_api_15_frontend.yml sub-config but had it looking for certain artifacts.

The push:
https://bugzilla.mozilla.org/show_bug.cgi?id=1254605#c17
https://treeherder.mozilla.org/#/jobs?repo=try&revision=3370dfbb8892

The "lint" job is green and when I inspect the task, it looks like the artifacts are present:
https://tools.taskcluster.net/task-inspector/#GBKMJwliQ4WihDnaQjOU2g/0

However, when I click through to the artifacts, I see "file-missing-on-worker":
https://queue.taskcluster.net/v1/task/GBKMJwliQ4WihDnaQjOU2g/runs/0/artifacts/public%2Fandroid%2Flint%2Flint-results-automationDebug.html

I'd expect one or both of:
* The job is red
* The inspected task alerts me that expected artifacts were not found.

fwiw, I don't have a good understanding of the system (i.e. I was largely copy-pasting previous tasks).
I agree this is broken, but I haven't a clue what system is failing.  TC -> TH seems to be completely unsolved.  selena, perhaps you can redirect?
Flags: needinfo?(sdeckelmann)
(Assignee)

Comment 2

2 years ago
Currently artifacts that are not found upon task completion will not cause a task to fail.  It was attempted to change this behavior at one point, but then soon it was discovered that tasks started being marked as failed because task creators were not warned of this change in behavior. Bug 1157425 was opened to work on this issue (I can start on that soon). (see also https://bugzilla.mozilla.org/show_bug.cgi?id=1222125#c6)

In regards to tasks missing artifacts, when inspecting the task in the task inspector, we display a couple of pieces of information indicating that the artifact was not found.  An error artifact will be created for each artifact not found that was declared within the task definition.  These are the artifacts that you see when inspecting the task will display an error reason of "file-missing-on-worker" when clicked.

There is also information at the end of the task log explaining what artifacts could not be found that were declared within the task payload.  Here is one such line from the task mentioned in the bug description:

[taskcluster 2016-03-29 22:15:17.650Z] Artifact "public/android/lint/lint-results-automationDebug.xml" not found at "/home/worker/workspace/build/src/obj-firefox/gradle/build/mobile/android/app/outputs/lint-results-automationDebug.xml"


I started an interactive task to locate these files within the task but could not find them.
Flags: needinfo?(sdeckelmann)
(Assignee)

Updated

2 years ago
Assignee: nobody → garndt
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1157425
You need to log in before you can comment on or make changes to this bug.