new messages appearing at top regardless of sort order

VERIFIED DUPLICATE of bug 129821

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 129821
17 years ago
14 years ago

People

(Reporter: Michael Wardle, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I haven't noticed this problem in earlier Mozillas, so it /could/ be a regression.

When a new message arrives, it is always placed at the top of the thread list,
regardless of sort order.  If the sort order is oldest->newest, the new message
should appear at the bottom.

build: 2002020406 (0.9.8) on Win2k/i386

steps to reproduce:
1. open mailnews
2. select a commonly-used folder (e.g. inbox)
3. scroll thread pane view to bottom
4. receive a message in that folder

The message count will be incremented in the folder view pane (on the left), but
no new message will appear at or near the bottom -- it will actually be at the top.

It seems that changing to a different folder then coming back will reorder the
thread view accordingly, and the new message will now be at the bottom.

Note: it may be necessary for MailNews (and the selected folder) to remain
focussed the entire time -- if I focus the browser window then go back to
MailNews, I'm not sure that the problem occurs.

Updated

17 years ago
QA Contact: esther → laurel
(Reporter)

Comment 1

17 years ago
possibly related bo bug 50938
(Reporter)

Comment 2

17 years ago
I'm seeing this even more frequently in build 2002031104 (0.9.9).

This is at least normal severity.
Severity: minor → normal
(Reporter)

Comment 3

17 years ago
Couldn't make the other bug a dupe of this one, so I'll do it the other way.


*** This bug has been marked as a duplicate of 129821 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
marking verified as duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.