Closed Bug 1261023 Opened 5 years ago Closed 5 years ago

cloning aurora and beta still result in 403

Categories

(Developer Services :: Mercurial: hg.mozilla.org, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: cbook, Assigned: fubar)

References

Details

not sure if this is the same issue as bug 1260652 

Tomcats-MacBook-Pro-2:test Tomcat$ hg clone https://hg.mozilla.org/releases/mozilla-aurora --traceback
destination directory: mozilla-aurora
applying clone bundle from https://hg.cdn.mozilla.net/releases/mozilla-aurora/876a1f819d83ef8035e579dd9247693c9526875b.gzip.hg
HTTP error fetching bundle: HTTP Error 403: Forbidden
Traceback (most recent call last):
  File "/usr/local/Cellar/mercurial/3.7.3/lib/python2.7/site-packages/mercurial/dispatch.py", line 191, in _runcatch
    return _dispatch(req)
  File "/usr/local/Cellar/mercurial/3.7.3/lib/python2.7/site-packages/mercurial/dispatch.py", line 924, in _dispatch
    cmdpats, cmdoptions)
  File "/usr/local/Cellar/mercurial/3.7.3/lib/python2.7/site-packages/mercurial/dispatch.py", line 681, in runcommand
    ret = _runcommand(ui, options, cmd, d)
  File "/usr/local/Cellar/mercurial/3.7.3/lib/python2.7/site-packages/mercurial/dispatch.py", line 1055, in _runcommand
    return checkargs()
  File "/usr/local/Cellar/mercurial/3.7.3/lib/python2.7/site-packages/mercurial/dispatch.py", line 1015, in checkargs
    return cmdfunc()
  File "/usr/local/Cellar/mercurial/3.7.3/lib/python2.7/site-packages/mercurial/dispatch.py", line 921, in <lambda>
    d = lambda: util.checksignature(func)(ui, *args, **cmdoptions)
  File "/usr/local/Cellar/mercurial/3.7.3/lib/python2.7/site-packages/mercurial/util.py", line 991, in check
    return func(*args, **kwargs)
  File "/usr/local/Cellar/mercurial/3.7.3/lib/python2.7/site-packages/mercurial/commands.py", line 1563, in clone
    shareopts=opts.get('shareopts'))
  File "/usr/local/Cellar/mercurial/3.7.3/lib/python2.7/site-packages/mercurial/hg.py", line 595, in clone
    streamclonerequested=stream)
  File "/usr/local/Cellar/mercurial/3.7.3/lib/python2.7/site-packages/mercurial/extensions.py", line 195, in closure
    return func(*(args + a), **kw)
  File "/Users/Tomcat/.mozbuild/version-control-tools/hgext/firefoxtree/__init__.py", line 337, in pull
    res = orig(repo, remote, *args, **kwargs)
  File "/usr/local/Cellar/mercurial/3.7.3/lib/python2.7/site-packages/mercurial/exchange.py", line 1185, in pull
    _maybeapplyclonebundle(pullop)
  File "/usr/local/Cellar/mercurial/3.7.3/lib/python2.7/site-packages/mercurial/exchange.py", line 1791, in _maybeapplyclonebundle
    hint=_('if this error persists, consider contacting '
Abort: error applying bundle
abort: error applying bundle
(if this error persists, consider contacting the server operator or disable clone bundles via "--config ui.clonebundles=false")
Tomcats-MacBook-Pro-2:test Tomcat$
seems this affect all trees (m-c, aurora, beta) 

hwine i guess you are aware so just as info
Flags: needinfo?(hwine)
Summary: cloning aurora still result in 403 → cloning aurora and beta still result in 403
Duplicate of this bug: 1260993
s3 bucket permissions were reset yesterday and the bucket policy needed adjusting. fixed that and am re-running the cron job; as it happens, since the trees are closed we generally don't need to create new bundles, so it should be done fairly quickly.
Assignee: nobody → klibby
m-c, c-c, releases/*, integration/*, v-c-t, and the few build bundles have all been uploaded and should be good to clone again. still working on projects/*, which will require at least one bundle rebuild, so those will be a little longer.
all bundles have been uploaded.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(hwine)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.