Closed Bug 1261109 Opened 4 years ago Closed 4 years ago

Firefox stops responding to mouse wheel events

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1257862
Tracking Status
firefox48 --- fixed

People

(Reporter: cpeterson, Unassigned)

Details

(Keywords: regression)

Firefox stops responding to scroll events from my trackpad. When this happens randomly, it affects all tabs including new or reloaded tabs.

I first saw this bug about a week ago and I've seen it about four times since then.

I have the following extensions installed:

about:media	2.3	true	aboutmedia@gavinsharp.com
alwaysright	1.5.0	true	jid0-SzimoL45Ib8OddgoUBG0buQmjec@jetpack
Bugzilla Tweaks	1.12.1.1.1-signed	true	jid0-qBnIpLfDFa4LpdrjhAC6vBqN20Q@jetpack
BugzillaJS	3.4.1-signed	true	jid0-NgMDcEu2B88AbzZ6ulHodW9sJzA@jetpack
FindBar Tweak	2.1.9	true	fbt@quicksaver
Firefox Hello Beta	1.2.2	true	loop@mozilla.org
Hide Twitter Guff	1.0.1-signed	true	jid1-56iCw3tsGm3w5g@jetpack
is.gd Creator (fork)	0.4.0	true	isgdcreator@mrkschan.at.gmail.com
Multi-process staged rollout	1.0	true	e10srollout@mozilla.org
Pocket	1.0	true	firefox@getpocket.com
Quora Share	0.1.1-signed	true	jid1-roegsJ40q6CsFg@jetpack
Twitter link expander	0.1.1-signed	true	jid1-DwRap1pOaj8qgQ@jetpack
uBlock Origin	1.6.4	true	uBlock0@raymondhill.net
You mean wheel events?

Is this with or without e10s?
Yes, I meant mouse wheel events.

I'm using Nightly 48 with e10s. I will test without e10s, but the problem is so intermittent that I will only be able to confirm that the problem happens without e10s if it actually happens.
Summary: Firefox stops responding to scroll events → Firefox stops responding to mouse wheel events
Kats, could this problem be related to any APZ changes that have landed over the past week?
Flags: needinfo?(bugmail.mozilla)
Yeah, dupe of bug 1257862. I'll land the fix for it today.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(bugmail.mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1257862
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.